summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2006-05-12 20:31:46 +0000
committerEldad Zack <eldad@gentoo.org>2006-05-12 20:31:46 +0000
commit75badac2b9d93d5cd947d6fa48fabd8ef2defb1d (patch)
treeaf90210296c75e34ea934521260b0b81b48e70ce /net-analyzer/nagios-core
parentInclude a new USE flag "force-reg" and don't --enable-force-reg by default; F... (diff)
downloadgentoo-2-75badac2b9d93d5cd947d6fa48fabd8ef2defb1d.tar.gz
gentoo-2-75badac2b9d93d5cd947d6fa48fabd8ef2defb1d.tar.bz2
gentoo-2-75badac2b9d93d5cd947d6fa48fabd8ef2defb1d.zip
Fixed enewuser behaviour, Closes Bug #133127.
(Portage version: 2.0.54-r2)
Diffstat (limited to 'net-analyzer/nagios-core')
-rw-r--r--net-analyzer/nagios-core/ChangeLog7
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.4.ebuild5
-rw-r--r--net-analyzer/nagios-core/nagios-core-2.3.ebuild5
3 files changed, 10 insertions, 7 deletions
diff --git a/net-analyzer/nagios-core/ChangeLog b/net-analyzer/nagios-core/ChangeLog
index 17a0e2791224..666602140c92 100644
--- a/net-analyzer/nagios-core/ChangeLog
+++ b/net-analyzer/nagios-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nagios-core
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.81 2006/05/07 20:17:11 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.82 2006/05/12 20:31:46 eldad Exp $
+
+ 12 May 2006; Eldad Zack <eldad@gentoo.org> nagios-core-1.4.ebuild,
+ nagios-core-2.3.ebuild:
+ Fixed enewuser behaviour, Closes Bug #133127. Thanks to Christian Gut
+ <cycloon@is-root.org>.
07 May 2006; Markus Rothe <corsair@gentoo.org> nagios-core-1.4.ebuild:
Stable on ppc64
diff --git a/net-analyzer/nagios-core/nagios-core-1.4.ebuild b/net-analyzer/nagios-core/nagios-core-1.4.ebuild
index 1d4dfe5b6677..541a81924b0a 100644
--- a/net-analyzer/nagios-core/nagios-core-1.4.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.4.ebuild,v 1.5 2006/05/07 20:17:11 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.4.ebuild,v 1.6 2006/05/12 20:31:46 eldad Exp $
inherit eutils apache-module toolchain-funcs
@@ -45,8 +45,7 @@ pkg_setup() {
if use noweb; then
enewuser nagios -1 /bin/bash /dev/null nagios
else
- enewuser nagios -1 /bin/bash /dev/null apache
- usermod -G apache nagios
+ enewuser nagios -1 /bin/bash /dev/null nagios,apache
fi
}
diff --git a/net-analyzer/nagios-core/nagios-core-2.3.ebuild b/net-analyzer/nagios-core/nagios-core-2.3.ebuild
index d2d0b064d06f..b153cc9a7670 100644
--- a/net-analyzer/nagios-core/nagios-core-2.3.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-2.3.ebuild,v 1.1 2006/05/03 18:29:13 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-2.3.ebuild,v 1.2 2006/05/12 20:31:46 eldad Exp $
inherit eutils apache-module toolchain-funcs gnuconfig
@@ -44,8 +44,7 @@ pkg_setup() {
if use noweb; then
enewuser nagios -1 /bin/bash /dev/null nagios
else
- enewuser nagios -1 /bin/bash /dev/null apache
- usermod -G apache nagios
+ enewuser nagios -1 /bin/bash /dev/null nagios,apache
fi
}