summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-26 18:34:58 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-26 18:34:58 +0000
commit3e8ed594df8e8e5065733e81fbb7b2f62255636f (patch)
tree94297f58373b6650fb304336796bd121dd675273 /net-analyzer/nagios-nsca/nagios-nsca-2.4.ebuild
parentVersion bumped. (diff)
downloadgentoo-2-3e8ed594df8e8e5065733e81fbb7b2f62255636f.tar.gz
gentoo-2-3e8ed594df8e8e5065733e81fbb7b2f62255636f.tar.bz2
gentoo-2-3e8ed594df8e8e5065733e81fbb7b2f62255636f.zip
Version bumped.
Diffstat (limited to 'net-analyzer/nagios-nsca/nagios-nsca-2.4.ebuild')
-rw-r--r--net-analyzer/nagios-nsca/nagios-nsca-2.4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/nagios-nsca/nagios-nsca-2.4.ebuild b/net-analyzer/nagios-nsca/nagios-nsca-2.4.ebuild
new file mode 100644
index 000000000000..801721743492
--- /dev/null
+++ b/net-analyzer/nagios-nsca/nagios-nsca-2.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-nsca/nagios-nsca-2.4.ebuild,v 1.1 2003/11/26 18:34:52 mholzer Exp $
+
+DESCRIPTION="Nagios $PV NSCA - Nagios Service Check Acceptor"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="mirror://sourceforge/nagios/nsca-${PV}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+DEPEND=">=net-analyzer/nagios-plugins-1.3.0
+ >=libmcrypt-2.5.1-r4"
+S="${WORKDIR}/nsca-${PV}"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr/nagios \
+ --localstatedir=/var/nagios \
+ --sysconfdir=/etc/nagios \
+ --with-nsca-user=nagios \
+ --with-nsca-grp=nagios \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake all || die
+}
+
+src_install() {
+ dodoc LEGAL Changelog README SECURITY
+ insinto /etc/nagios
+ doins ${FILESDIR}/nsca.cfg
+ doins ${FILESDIR}/send_nsca.cfg
+ exeinto /usr/nagios/bin
+ doexe src/nsca
+ fowners nagios:nagios /usr/nagios/bin/nsca
+ exeinto /usr/nagios/libexec
+ doexe src/send_nsca
+ fowners nagios:nagios /usr/nagios/libexec/send_nsca
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/nsca-2.3 nsca
+}
+pkg_postinst() {
+ einfo
+ einfo "If you are using the nsca daemon, remember to edit"
+ einfo "the config file /etc/nagios/nsca.cfg"
+ einfo
+}