summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-06-19 20:13:16 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-06-19 20:13:16 +0000
commit7891b8f656006f50ddec8ed16a7a3c871625e3a5 (patch)
tree54487a5c279bc4832920232d071449346c0b5041 /net-analyzer/nagvis
parentversion bump (diff)
downloadgentoo-2-7891b8f656006f50ddec8ed16a7a3c871625e3a5.tar.gz
gentoo-2-7891b8f656006f50ddec8ed16a7a3c871625e3a5.tar.bz2
gentoo-2-7891b8f656006f50ddec8ed16a7a3c871625e3a5.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nagvis')
-rw-r--r--net-analyzer/nagvis/ChangeLog8
-rw-r--r--net-analyzer/nagvis/nagvis-1.4.1.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/net-analyzer/nagvis/ChangeLog b/net-analyzer/nagvis/ChangeLog
index f92763fd1fa7..0f8937869586 100644
--- a/net-analyzer/nagvis/ChangeLog
+++ b/net-analyzer/nagvis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nagvis
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagvis/ChangeLog,v 1.4 2009/06/19 18:22:08 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagvis/ChangeLog,v 1.5 2009/06/19 20:13:16 dertobi123 Exp $
+
+*nagvis-1.4.1 (19 Jun 2009)
+
+ 19 Jun 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ +nagvis-1.4.1.ebuild:
+ Version bump
19 Jun 2009; Tobias Scherbaum <dertobi123@gentoo.org> nagvis-1.3.2.ebuild:
Fix elog message, #274485
diff --git a/net-analyzer/nagvis/nagvis-1.4.1.ebuild b/net-analyzer/nagvis/nagvis-1.4.1.ebuild
new file mode 100644
index 000000000000..f5353107b369
--- /dev/null
+++ b/net-analyzer/nagvis/nagvis-1.4.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagvis/nagvis-1.4.1.ebuild,v 1.1 2009/06/19 20:13:16 dertobi123 Exp $
+
+inherit eutils confutils depend.php
+
+DESCRIPTION="NagVis is a visualization addon for the well known network managment system Nagios."
+HOMEPAGE="http://www.nagvis.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="automap"
+
+DEPEND=""
+RDEPEND=">=net-analyzer/ndoutils-1.4_beta4
+ automap? ( >=media-gfx/graphviz-2.14 )"
+
+need_php_httpd
+
+pkg_setup() {
+ confutils_require_built_with_all dev-lang/php gd mysql unicode
+}
+
+src_install() {
+ for docfile in README INSTALL
+ do
+ dodoc ${docfile}
+ rm ${docfile}
+ done
+
+ grep -Rl "/usr/local" "${S}"/* | xargs sed -i s:/usr/local:/usr:g
+
+ dodir /usr/share/nagvis
+ mv "${S}"/{config.php,index.php,nagvis,wui} "${D}"/usr/share/nagvis/
+
+ dodir /var/nagvis
+ dosym /var/nagvis /usr/share/nagvis/var
+ fowners apache:root /var/nagvis
+
+ dodir /etc/nagvis
+ mv "${S}"/etc/* "${D}"/etc/nagvis/
+ dosym /etc/nagvis /usr/share/nagvis/etc
+
+ fperms 664 /etc/nagvis/nagvis.ini.php-sample
+ fperms 775 /etc/nagvis/maps
+ fowners apache:root /etc/nagvis/maps
+ fperms 664 /etc/nagvis/maps/*cfg
+ fowners apache:root /etc/nagvis/maps/*cfg
+}
+
+pkg_postinst() {
+ elog "Before running NagVis for the first time, you will need to set up"
+ elog "/etc/nagvis/nagvis.ini.php"
+ elog "A sample is in"
+ elog "/etc/nagvis/nagvis.ini.php-sample"
+}