summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-06 17:35:27 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-06 17:35:27 +0000
commit2b0f9bb3e24e0edeb4bc145f05d39fb91b8f8c9b (patch)
tree65abb4d2894747445a96e604422ef8bccedbf800 /net-analyzer/nessus-bin
parentalpha/ia64/sparc stable wrt #437026 (diff)
downloadgentoo-2-2b0f9bb3e24e0edeb4bc145f05d39fb91b8f8c9b.tar.gz
gentoo-2-2b0f9bb3e24e0edeb4bc145f05d39fb91b8f8c9b.tar.bz2
gentoo-2-2b0f9bb3e24e0edeb4bc145f05d39fb91b8f8c9b.zip
Version bump wrt bug #437376
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nessus-bin')
-rw-r--r--net-analyzer/nessus-bin/ChangeLog7
-rw-r--r--net-analyzer/nessus-bin/nessus-bin-5.0.1.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/net-analyzer/nessus-bin/ChangeLog b/net-analyzer/nessus-bin/ChangeLog
index 63308b737ce7..355142de7910 100644
--- a/net-analyzer/nessus-bin/ChangeLog
+++ b/net-analyzer/nessus-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nessus-bin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/ChangeLog,v 1.16 2012/09/13 07:14:05 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/ChangeLog,v 1.17 2012/10/06 17:35:27 pinkbyte Exp $
+
+*nessus-bin-5.0.1 (06 Oct 2012)
+
+ 06 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> +nessus-bin-5.0.1.ebuild:
+ Version bump wrt bug #437376
13 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> nessus-bin-4.4.1.ebuild:
Add GPL-2 to LICENSE variable, cause init.d script are under it, wrt bug
diff --git a/net-analyzer/nessus-bin/nessus-bin-5.0.1.ebuild b/net-analyzer/nessus-bin/nessus-bin-5.0.1.ebuild
new file mode 100644
index 000000000000..b0e1f25a037c
--- /dev/null
+++ b/net-analyzer/nessus-bin/nessus-bin-5.0.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-bin/nessus-bin-5.0.1.ebuild,v 1.1 2012/10/06 17:35:27 pinkbyte Exp $
+
+inherit multilib rpm
+
+MY_P="Nessus-${PV}-es6"
+# We are using the Red Hat/CentOS binary
+
+DESCRIPTION="A remote security scanner for Linux"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="
+ x86? ( ${MY_P}.i686.rpm )
+ amd64? ( ${MY_P}.x86_64.rpm )"
+
+RESTRICT="mirror fetch strip"
+
+LICENSE="GPL-2 Nessus-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="X"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from ${HOMEPAGE}/download"
+ einfo "The archive should then be placed into ${DISTDIR}."
+}
+
+src_install() {
+ cp -pPR "${WORKDIR}"/opt "${D}"/
+
+ # make sure these directories do not vanish
+ # nessus will not run properly without them
+ keepdir /opt/nessus/etc/nessus
+ keepdir /opt/nessus/var/nessus/jobs
+ keepdir /opt/nessus/var/nessus/logs
+ keepdir /opt/nessus/var/nessus/tmp
+ keepdir /opt/nessus/var/nessus/users
+
+ # add PATH and MANPATH for convenience
+ doenvd "${FILESDIR}"/90nessus-bin
+
+ # init script
+ newinitd "${FILESDIR}"/nessusd-initd nessusd-bin
+ dosym libssl.so /usr/$(get_libdir)/libssl.so.10
+ dosym libcrypto.so /usr/$(get_libdir)/libcrypto.so.10
+}
+
+pkg_postinst() {
+ elog "You can get started running the following commands:"
+ elog "/opt/nessus/sbin/nessus-adduser"
+ elog "/opt/nessus/sbin/nessus-mkcert"
+ elog "/opt/nessus/bin/nessus-fetch --register <your registration code>"
+ elog "/etc/init.d/nessusd-bin start"
+ elog
+ elog "If you had a previous version of Nessus installed, use"
+ elog "the following command to update the plugin database:"
+ elog "/opt/nessus/sbin/nessusd -R"
+ elog
+ elog "For more information about nessus, please visit"
+ elog "${HOMEPAGE}/documentation/"
+}