summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-02-26 08:10:29 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-02-26 08:10:29 +0000
commit15ef83e07d72aab1f5e67d4c81e5d8c453527723 (patch)
tree0a96b27b514d655a14079c6a332fba9df478da1f /net-analyzer/nessus-core
parentShould execute zpasswd with python, to avoid a bug when converting a float to... (diff)
downloadgentoo-2-15ef83e07d72aab1f5e67d4c81e5d8c453527723.tar.gz
gentoo-2-15ef83e07d72aab1f5e67d4c81e5d8c453527723.tar.bz2
gentoo-2-15ef83e07d72aab1f5e67d4c81e5d8c453527723.zip
Version bump
Diffstat (limited to 'net-analyzer/nessus-core')
-rw-r--r--net-analyzer/nessus-core/ChangeLog7
-rw-r--r--net-analyzer/nessus-core/files/digest-nessus-core-2.0.01
-rw-r--r--net-analyzer/nessus-core/nessus-core-2.0.0.ebuild56
3 files changed, 63 insertions, 1 deletions
diff --git a/net-analyzer/nessus-core/ChangeLog b/net-analyzer/nessus-core/ChangeLog
index 4a850a308fe7..02fe2e19b9e9 100644
--- a/net-analyzer/nessus-core/ChangeLog
+++ b/net-analyzer/nessus-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nessus-core
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/ChangeLog,v 1.12 2003/02/12 07:47:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/ChangeLog,v 1.13 2003/02/26 08:09:43 aliz Exp $
+
+*nessus-core-2.0.0 (25 Feb 2003)
+
+ 25 Feb 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump. Ebuild submitted by Blu3 <david+gentoo.org@blue-labs.org> in #16310.
*nessus-core-1.2.7 (04 Jan 2003)
diff --git a/net-analyzer/nessus-core/files/digest-nessus-core-2.0.0 b/net-analyzer/nessus-core/files/digest-nessus-core-2.0.0
new file mode 100644
index 000000000000..10473f8cd7e1
--- /dev/null
+++ b/net-analyzer/nessus-core/files/digest-nessus-core-2.0.0
@@ -0,0 +1 @@
+MD5 862546873b999ee23ee0bb6974df728c nessus-core-2.0.0.tar.gz 644879
diff --git a/net-analyzer/nessus-core/nessus-core-2.0.0.ebuild b/net-analyzer/nessus-core/nessus-core-2.0.0.ebuild
new file mode 100644
index 000000000000..b902f1f8ffad
--- /dev/null
+++ b/net-analyzer/nessus-core/nessus-core-2.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-2.0.0.ebuild,v 1.1 2003/02/26 08:09:43 aliz Exp $
+
+IUSE="tcpd X gtk gtk2"
+S=${WORKDIR}/${PN}
+DESCRIPTION="A remote security scanner for Linux (nessus-core)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
+DEPEND="=net-analyzer/libnasl-${PV}
+ tcpd? ( sys-apps/tcp-wrappers )
+ X? ( x11-base/xfree )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( =x11-libs/gtk+-2* )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc -sparc ~alpha"
+
+src_compile() {
+ local myconf
+ use X && myconf="--with-x" || myconf="--without-x"
+ if [ `use gtk` ]; then
+ myconf="${myconf} --enable-gtk"
+ elif [ `use gtk2`]; then
+ myconf="${myconf} --enable-gtk"
+ else
+ myconf="${myconf} --disable-gtk"
+ fi
+ use tcpd && myconf="${myconf} --enable-tcpwrappers" \
+ || myconf="${myconf} --disable-tcpwrappers"
+ if [ ! -z $DEBUGBUILD ]; then
+ myconf="${myconf} --enable-debug"
+ else
+ myconf="${myconf} --disable-debug"
+ fi
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ mandir=${D}/usr/share/man \
+ install || die "Install failed nessus-core"
+ cd ${S}
+ dodoc README* UPGRADE_README CHANGES
+ dodoc doc/*.txt doc/ntp/*
+ insinto /etc/init.d
+ insopts -m 755
+ newins ${FILESDIR}/nessusd-r6 nessusd
+ keepdir /var/lib/nessus/logs
+ keepdir /var/lib/nessus/users
+}