summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-22 08:15:23 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-22 08:15:23 +0000
commitd684f2b712038b9c660e91afcb68d010f312fbdc (patch)
tree24e9a9da8eb9d7c40b86a3500e62f2d73e425dbc /net-analyzer/netcat
parentfixed spacing (diff)
downloadgentoo-2-d684f2b712038b9c660e91afcb68d010f312fbdc.tar.gz
gentoo-2-d684f2b712038b9c660e91afcb68d010f312fbdc.tar.bz2
gentoo-2-d684f2b712038b9c660e91afcb68d010f312fbdc.zip
nc->netcat binary name
Diffstat (limited to 'net-analyzer/netcat')
-rw-r--r--net-analyzer/netcat/ChangeLog11
-rw-r--r--net-analyzer/netcat/files/digest-netcat-110-r11
-rw-r--r--net-analyzer/netcat/netcat-110-r1.ebuild45
3 files changed, 56 insertions, 1 deletions
diff --git a/net-analyzer/netcat/ChangeLog b/net-analyzer/netcat/ChangeLog
index bc7c04810ebb..03de6bcbe64f 100644
--- a/net-analyzer/netcat/ChangeLog
+++ b/net-analyzer/netcat/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-analyzer/netcat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/ChangeLog,v 1.3 2002/08/30 16:36:37 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/ChangeLog,v 1.4 2002/10/22 08:15:23 seemant Exp $
+
+*netcat-110-r1 (22 Oct 2002)
+
+ 22 Oct 2002; Seemant Kulleen <seemant@gentoo.org> netcat-110-r1.ebuild
+ files/digest-netcat-110-r1 :
+
+ The executable is now installed as /usr/bin/netcat instead of /usr/bin/nc
+ which conflicted with /usr/bin/nc from app-editors/nedit. Closes bug
+ #6370 by Klaus.Kusche@inode.at (Klaus Kusche)
*netcat-110 (1 Feb 2002)
diff --git a/net-analyzer/netcat/files/digest-netcat-110-r1 b/net-analyzer/netcat/files/digest-netcat-110-r1
new file mode 100644
index 000000000000..fe2640793b1d
--- /dev/null
+++ b/net-analyzer/netcat/files/digest-netcat-110-r1
@@ -0,0 +1 @@
+MD5 402632f2fe01c169ff19a0ad6e9d608c nc110.tgz 75267
diff --git a/net-analyzer/netcat/netcat-110-r1.ebuild b/net-analyzer/netcat/netcat-110-r1.ebuild
new file mode 100644
index 000000000000..b654ed79ac54
--- /dev/null
+++ b/net-analyzer/netcat/netcat-110-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/netcat-110-r1.ebuild,v 1.1 2002/10/22 08:15:23 seemant Exp $
+
+MY_P=nc${PV}
+S=${WORKDIR}
+DESCRIPTION="A network piping program"
+SRC_URI="http://www.l0pht.com/~weld/netcat/${MY_P}.tgz"
+HOMEPAGE="http://www.l0pht.com/~weld/netcat"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="sys-apps/supersed"
+
+src_compile() {
+
+ einfo "Makefile corrections"
+ ssed -i \
+ -e "s:^CFLAGS =.*$:CFLAGS = ${CFLAGS}:" \
+ -e "s:^CC =.*$:CC = gcc \$(CFLAGS):" \
+ -e "s:nc:netcat:g" \
+ Makefile
+
+ einfo "netcat.c corrections"
+ ssed -i "s:#define HAVE_BIND:#undef HAVE_BIND:" \
+ netcat.c
+
+ make linux || die
+
+}
+
+src_install () {
+ dobin netcat
+ dodoc README
+ docinto scripts
+ dodoc scripts/*
+}
+
+pkg_postinst() {
+ einfo "The binary is now installed as /usr/bin/netcat instead of"
+ einfo "/usr/bin/nc, because the latter is provided by"
+ einfo "app-editors/nedit for a completely different purpose."
+}