summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-09-10 18:39:28 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-09-10 18:39:28 +0000
commit2f4168084d3eeeb0b180e9860b60ac96ebc866ce (patch)
tree7c84c4b15054fed678929d04568a95ffd8ce98aa /net-analyzer/nmap
parentVersion bump (diff)
downloadgentoo-2-2f4168084d3eeeb0b180e9860b60ac96ebc866ce.tar.gz
gentoo-2-2f4168084d3eeeb0b180e9860b60ac96ebc866ce.tar.bz2
gentoo-2-2f4168084d3eeeb0b180e9860b60ac96ebc866ce.zip
fix bug #237150, compiling with USE='-lua'. Fix from Simon Zilliken <simon@zilliken.name>
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r8 x86_64)
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog7
-rw-r--r--net-analyzer/nmap/files/nmap-4.75-nolua.patch10
-rw-r--r--net-analyzer/nmap/nmap-4.75.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 03bbce5f5608..01599191736d 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.183 2008/09/09 07:05:53 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.184 2008/09/10 18:39:27 cardoe Exp $
+
+ 10 Sep 2008; Doug Goldstein <cardoe@gentoo.org>
+ +files/nmap-4.75-nolua.patch, nmap-4.75.ebuild:
+ fix bug #237150, compiling with USE='-lua'. Fix from Simon Zilliken
+ <simon@zilliken.name>
*nmap-4.75 (09 Sep 2008)
diff --git a/net-analyzer/nmap/files/nmap-4.75-nolua.patch b/net-analyzer/nmap/files/nmap-4.75-nolua.patch
new file mode 100644
index 000000000000..30bb1e0c8669
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-4.75-nolua.patch
@@ -0,0 +1,10 @@
+diff -Naur nmap-4.75-orig/Makefile.in nmap-4.75/Makefile.in
+--- nmap-4.75-orig/Makefile.in 2008-09-05 07:32:06.000000000 +0200
++++ nmap-4.75/Makefile.in 2008-09-09 16:34:38.000000000 +0200
+@@ -258,5 +258,5 @@
+ ./config.status --recheck
+
+ makefile.dep:
+- $(CXX) -MM $(CPPFLAGS) $(SRCS) > $@
++ $(CXX) -MM $(CPPFLAGS) $(CXXFLAGS) $(SRCS) > $@
+ include makefile.dep
diff --git a/net-analyzer/nmap/nmap-4.75.ebuild b/net-analyzer/nmap/nmap-4.75.ebuild
index 98c75ebd68b1..3172bb02cf0a 100644
--- a/net-analyzer/nmap/nmap-4.75.ebuild
+++ b/net-analyzer/nmap/nmap-4.75.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.75.ebuild,v 1.1 2008/09/09 07:05:53 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.75.ebuild,v 1.2 2008/09/10 18:39:27 cardoe Exp $
inherit eutils flag-o-matic
@@ -36,6 +36,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-include.patch"
+ epatch "${FILESDIR}/${P}-nolua.patch"
}
src_compile() {