summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-07-12 11:14:53 +0000
committerEldad Zack <eldad@gentoo.org>2004-07-12 11:14:53 +0000
commit7340d09ab2b397629092508fa300b3e41d38d79b (patch)
tree2e53e04426e583c3cc22db8925a8bb44271e8dcf /net-analyzer/packit/packit-1.0.ebuild
parentAdded new 1.0.4 version which improves handling of some autoconfig functions ... (diff)
downloadgentoo-2-7340d09ab2b397629092508fa300b3e41d38d79b.tar.gz
gentoo-2-7340d09ab2b397629092508fa300b3e41d38d79b.tar.bz2
gentoo-2-7340d09ab2b397629092508fa300b3e41d38d79b.zip
bump
Diffstat (limited to 'net-analyzer/packit/packit-1.0.ebuild')
-rw-r--r--net-analyzer/packit/packit-1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/packit/packit-1.0.ebuild b/net-analyzer/packit/packit-1.0.ebuild
new file mode 100644
index 000000000000..ee88e885154b
--- /dev/null
+++ b/net-analyzer/packit/packit-1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/packit/packit-1.0.ebuild,v 1.1 2004/07/12 11:14:53 eldad Exp $
+
+inherit eutils
+
+DESCRIPTION="network auditing tool that allows you to monitor, manipulate, and inject customized IPv4 traffic"
+HOMEPAGE="http://www.packetfactory.net/projects/packit/"
+SRC_URI="http://www.packetfactory.net/projects/packit/downloads/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=net-libs/libnet-1.1.2*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ has_version '>=net-libs/libpcap-0.8.1' \
+ && sed -i 's!^#include <net/bpf.h>$!#include <pcap-bpf.h>!' \
+ src/{globals,main}.h
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc INSTALL LICENSE VERSION docs/*
+}