summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-23 16:01:17 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-23 16:01:17 +0000
commitc30fa6da62bc040fa050030b49ca59fb17475858 (patch)
tree9b3b9b160f576b8989405c9d881cfa1da5961c19 /net-analyzer/pmacct
parentMarking neon-0.29.3 ppc64 for bug 305181 (diff)
downloadgentoo-2-c30fa6da62bc040fa050030b49ca59fb17475858.tar.gz
gentoo-2-c30fa6da62bc040fa050030b49ca59fb17475858.tar.bz2
gentoo-2-c30fa6da62bc040fa050030b49ca59fb17475858.zip
Version bump thanks to Marcin Mirosław (bug #306531).
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/pmacct')
-rw-r--r--net-analyzer/pmacct/ChangeLog9
-rw-r--r--net-analyzer/pmacct/pmacct-0.12.0.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index a62215f71fb3..e24a8ac84664 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/pmacct
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.61 2009/06/01 09:48:36 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.62 2010/02/23 16:01:17 jer Exp $
+
+*pmacct-0.12.0 (23 Feb 2010)
+
+ 23 Feb 2010; Jeroen Roovers <jer@gentoo.org> +pmacct-0.12.0.ebuild:
+ Version bump thanks to Marcin Mirosław (bug #306531).
01 Jun 2009; Peter Volkov <pva@gentoo.org> -pmacct-0.11.3.ebuild,
-pmacct-0.11.4.ebuild, pmacct-0.11.5-r1.ebuild, files/pmacctd-init.d,
diff --git a/net-analyzer/pmacct/pmacct-0.12.0.ebuild b/net-analyzer/pmacct/pmacct-0.12.0.ebuild
new file mode 100644
index 000000000000..5380e1d65040
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-0.12.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.12.0.ebuild,v 1.1 2010/02/23 16:01:17 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.pmacct.net/"
+SRC_URI="http://www.pmacct.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="64bit debug ipv6 mmap mysql postgres sqlite"
+
+RDEPEND="net-libs/libpcap
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )
+ sqlite? ( =dev-db/sqlite-3* )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable mmap) \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_enable 64bit) \
+ $(use_enable sqlite sqlite3)
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
+ docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+
+ for dirname in examples sql; do
+ docinto ${dirname}
+ dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+ done
+
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
+ newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+ insinto /etc
+ newins "${S}/examples/pmacctd-imt.conf.example" pmacctd.conf || \
+ die "newins failed"
+}