summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-03-05 14:37:09 +0000
committerEray Aslan <eras@gentoo.org>2012-03-05 14:37:09 +0000
commit94997673b91de655ccb4ee759b1d17200b6ea088 (patch)
treefb2aa04e804693dd8f7fd545a966ac01543898af /net-analyzer/postal/postal-0.72.ebuild
parentdxr3 unmask, works with v4l2, #350211 (diff)
downloadgentoo-2-94997673b91de655ccb4ee759b1d17200b6ea088.tar.gz
gentoo-2-94997673b91de655ccb4ee759b1d17200b6ea088.tar.bz2
gentoo-2-94997673b91de655ccb4ee759b1d17200b6ea088.zip
version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/postal/postal-0.72.ebuild')
-rw-r--r--net-analyzer/postal/postal-0.72.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/postal/postal-0.72.ebuild b/net-analyzer/postal/postal-0.72.ebuild
new file mode 100644
index 000000000000..542f94255fc3
--- /dev/null
+++ b/net-analyzer/postal/postal-0.72.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/postal/postal-0.72.ebuild,v 1.1 2012/03/05 14:37:09 eras Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="SMTP and POP mailserver benchmark. Supports SSL, randomized user accounts and more."
+HOMEPAGE="http://www.coker.com.au/postal/"
+SRC_URI="http://www.coker.com.au/postal/${P}.tgz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="ssl gnutls"
+#ssl is an alias for openssl. If both ssl and gnutls are enabled, automagic will
+#enable only gnutls.
+DEPEND="ssl? (
+ !gnutls? ( >=dev-libs/openssl-0.9.8g )
+ gnutls? ( >=net-libs/gnutls-2.2.2 )
+ )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/01_${PN}-0.70-gcc43.patch"
+ epatch "${FILESDIR}/02_${PN}-0.72-nossl.patch"
+ epatch "${FILESDIR}/03_${PN}-0.70-c++0x-integrated.patch"
+ epatch "${FILESDIR}/04_${PN}-0.70-warnings.patch"
+ epatch "${FILESDIR}/05_${PN}-0.70-openssl-1.patch"
+ epatch "${FILESDIR}/06_${PN}-0.70-ldflags.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-stripping \
+ $(use_enable ssl openssl) \
+ $(use_enable gnutls)
+}