summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-22 05:47:34 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-22 05:47:34 +0000
commit5817b561c600e49804631a04f80f78182d28973e (patch)
tree54670c22bf331279b81c3d53c8ca0a54925d162d /net-analyzer/tcpdump
parentFor gnome-session-3.6, fix upower suspend problems (bug #450150, thanks to Ti... (diff)
downloadgentoo-2-5817b561c600e49804631a04f80f78182d28973e.tar.gz
gentoo-2-5817b561c600e49804631a04f80f78182d28973e.tar.bz2
gentoo-2-5817b561c600e49804631a04f80f78182d28973e.zip
Fix from upstream for cross-compiling with ssl.
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'net-analyzer/tcpdump')
-rw-r--r--net-analyzer/tcpdump/ChangeLog8
-rw-r--r--net-analyzer/tcpdump/files/tcpdump-4.3.0-ssl-detect.patch125
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.3.0.ebuild15
3 files changed, 143 insertions, 5 deletions
diff --git a/net-analyzer/tcpdump/ChangeLog b/net-analyzer/tcpdump/ChangeLog
index 2fc80a3529a8..b7efc3d0e185 100644
--- a/net-analyzer/tcpdump/ChangeLog
+++ b/net-analyzer/tcpdump/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/tcpdump
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/ChangeLog,v 1.161 2012/12/07 16:23:51 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/ChangeLog,v 1.162 2013/01/22 05:47:34 vapier Exp $
+
+ 22 Jan 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/tcpdump-4.3.0-ssl-detect.patch, tcpdump-4.3.0.ebuild:
+ Fix from upstream for cross-compiling with ssl.
07 Dec 2012; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Clarify USE=chroot.
diff --git a/net-analyzer/tcpdump/files/tcpdump-4.3.0-ssl-detect.patch b/net-analyzer/tcpdump/files/tcpdump-4.3.0-ssl-detect.patch
new file mode 100644
index 000000000000..a4854372971a
--- /dev/null
+++ b/net-analyzer/tcpdump/files/tcpdump-4.3.0-ssl-detect.patch
@@ -0,0 +1,125 @@
+fix from upstream to drop ugly filesystem checks that fail horribly when cross-compiling
+
+From c4b7e5f2b287ee3d1de8f706b809a8e217720c4e Mon Sep 17 00:00:00 2001
+From: Marc Abramowitz <marc@marc-abramowitz.com>
+Date: Sat, 13 Oct 2012 11:21:45 -0700
+Subject: [PATCH] Simplify the detection of OpenSSL libcrypto by using
+ standard autoconf macros rather than a local copy of
+ AC_LBL_SSLEAY.
+
+AC_LBL_SSLEAY is old and has not kept pace with some more recent
+developments in packaging like Debian and Ubuntu's multiarch support.
+The autoconf macros have been updated to handle multiarch so using them
+means that tcpdump gains the ability to be built with libcrypto on these
+new multiarch distros and to work successfully with Travis CI, which
+uses Ubuntu 12, which is one such multiarch distro (see GH-32).
+
+Fixes GH-33
+---
+ configure | 11201 ++++++++++++++++++---------------------------------------
+ configure.in | 73 +-
+ 2 files changed, 3443 insertions(+), 7831 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 8864238..14a60e1 100644
+--- a/configure.in
++++ b/configure.in
+@@ -994,13 +994,13 @@ AC_LBL_UNALIGNED_ACCESS
+
+ AC_VAR_H_ERRNO
+
+-# Check for SSLeay
+-AC_MSG_CHECKING(whether to use SSLeay libcrypto)
++# Check for OpenSSL libcrypto
++AC_MSG_CHECKING(whether to use OpenSSL libcrypto)
+ # Specify location for both includes and libraries.
+-want_libcrypto=youmama
++want_libcrypto=ifavailable
+ AC_ARG_WITH(crypto,
+- AS_HELP_STRING([--with-crypto@<:@=PATH@:>@],
+- [use SSLeay libcrypto (located in directory PATH, if supplied). @<:@default=yes, if available@:>@]),
++ AS_HELP_STRING([--with-crypto],
++ [use OpenSSL libcrypto @<:@default=yes, if available@:>@]),
+ [
+ if test $withval = no
+ then
+@@ -1010,10 +1010,6 @@ AC_ARG_WITH(crypto,
+ then
+ want_libcrypto=yes
+ AC_MSG_RESULT(yes)
+- else
+- want_libcrypto=yes
+- AC_MSG_RESULT(yes)
+- crypto_dir=$withval
+ fi
+ ],[
+ #
+@@ -1023,63 +1019,8 @@ AC_ARG_WITH(crypto,
+ AC_MSG_RESULT([yes, if available])
+ ])
+ if test "$want_libcrypto" != "no"; then
+- ac_cv_ssleay_path=no
+- incdir=no
+- if test "x$crypto_dir" = x; then
+- #
+- # Location not specified; check the default locations.
+- #
+- AC_MSG_CHECKING(where SSLeay is located)
+- dirs="/usr /usr/local /usr/local/ssl /usr/pkg"
+- if test "x${host_alias}" != x; then
+- dirs="/usr/${host_alias} $dirs"
+- fi
+- for dir in $dirs; do
+- AC_LBL_SSLEAY($dir)
+-
+- if test "$ac_cv_ssleay_path" != "no" -a "$incdir" != "no"; then
+- break;
+- else
+- ac_cv_ssleay_path=no
+- incdir=no
+- fi
+- done
+- if test "$ac_cv_ssleay_path" != no; then
+- AC_MSG_RESULT($ac_cv_ssleay_path)
+- fi
+- else
+- AC_MSG_CHECKING(for SSLeay in $crypto_dir)
+- AC_LBL_SSLEAY($crypto_dir)
+- if test "$ac_cv_ssleay_path" != no; then
+- AC_MSG_RESULT(found)
+- fi
+- fi
+- if test "$ac_cv_ssleay_path" != no; then
+- V_INCLS="$V_INCLS $incdir"
+- if test "$dir" != "/usr"; then
+- LDFLAGS="-L$dir/lib $LDFLAGS"
+- fi
+- if test -f $ac_cv_ssleay_path/lib/libRSAglue.a; then
+- LIBS="$LIBS -lRSAglue"
+- fi
+- if test -f $ac_cv_ssleay_path/lib/librsaref.a; then
+- LIBS="$LIBS -lrsaref"
+- fi
+- AC_CHECK_LIB(crypto, DES_cbc_encrypt)
+-
+- savedcppflags="$CPPFLAGS"
+- CPPFLAGS="$CPPFLAGS $V_INCLS"
+- AC_CHECK_HEADERS(openssl/evp.h)
+- CPPFLAGS="$savedcppflags"
+- else
+- #
+- # Not found. Did the user explicitly ask for it?
+- #
+- AC_MSG_RESULT(not found)
+- if test "$want_libcrypto" = yes; then
+- AC_MSG_ERROR(SSLeay not found)
+- fi
+- fi
++ AC_CHECK_LIB(crypto, DES_cbc_encrypt)
++ AC_CHECK_HEADERS(openssl/evp.h)
+ fi
+
+ dnl
+--
+1.8.0
+
diff --git a/net-analyzer/tcpdump/tcpdump-4.3.0.ebuild b/net-analyzer/tcpdump/tcpdump-4.3.0.ebuild
index 44f3736ca81e..44cfb0204b31 100644
--- a/net-analyzer/tcpdump/tcpdump-4.3.0.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-4.3.0.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-4.3.0.ebuild,v 1.8 2012/09/30 16:39:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-4.3.0.ebuild,v 1.9 2013/01/22 05:47:34 vapier Exp $
EAPI="4"
-inherit flag-o-matic user
+
+AUTOTOOLS_AUTO_DEPEND="no" # Only cross-compiling
+inherit flag-o-matic user autotools eutils toolchain-funcs
DESCRIPTION="A Tool for network monitoring and data acquisition"
HOMEPAGE="http://www.tcpdump.org/"
@@ -44,6 +46,13 @@ pkg_setup() {
enewuser tcpdump -1 -1 -1 tcpdump
}
+src_prepare() {
+ if tc-is-cross-compiler ; then
+ epatch "${FILESDIR}"/${P}-ssl-detect.patch
+ eautoreconf
+ fi
+}
+
src_configure() {
# tcpdump needs some optymalization. see bug #108391
( ! is-flag -O? || is-flag -O0 ) && append-flags -O2