summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2008-05-14 02:02:08 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2008-05-14 02:02:08 +0000
commit9e14aeb89d03ac9b03e654ea1f58be28d88624a7 (patch)
tree519a6b2c5ce772b2b6e9a59c4de169f4deb72aa0 /net-analyzer/tcpstat/tcpstat-1.5-r1.ebuild
parentFix DEPEND-RDEPEND for bug 211145. Thanks to Jos� Manuel Ferrer Ortiz <jmfo19... (diff)
downloadgentoo-2-9e14aeb89d03ac9b03e654ea1f58be28d88624a7.tar.gz
gentoo-2-9e14aeb89d03ac9b03e654ea1f58be28d88624a7.tar.bz2
gentoo-2-9e14aeb89d03ac9b03e654ea1f58be28d88624a7.zip
Do not build tcpprof so that we do not depend on db-1.85-r3. Make ipv6 support
optional, install catpcap and packetdump. Fixes bug 221815, thanks to Peter Alfredsen <peter.alfredsen at gmail dot com>. (Portage version: 2.1.4.4)
Diffstat (limited to 'net-analyzer/tcpstat/tcpstat-1.5-r1.ebuild')
-rw-r--r--net-analyzer/tcpstat/tcpstat-1.5-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/tcpstat/tcpstat-1.5-r1.ebuild b/net-analyzer/tcpstat/tcpstat-1.5-r1.ebuild
new file mode 100644
index 000000000000..265b4bda252f
--- /dev/null
+++ b/net-analyzer/tcpstat/tcpstat-1.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpstat/tcpstat-1.5-r1.ebuild,v 1.1 2008/05/14 02:02:08 vanquirius Exp $
+
+inherit eutils autotools flag-o-matic
+
+DESCRIPTION="Reports network interface statistics"
+SRC_URI="http://www.frenchfries.net/paul/tcpstat/${P}.tar.gz"
+HOMEPAGE="http://www.frenchfries.net/paul/tcpstat/"
+
+DEPEND="net-libs/libpcap"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="ipv6"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-db.patch"
+ eautoreconf
+}
+
+src_compile() {
+ append-flags -Wall -Wextra
+ econf $(use_enable ipv6) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "emake install failed"
+ dobin src/{catpcap,packetdump} || die "dobin failed"
+ dodoc AUTHORS ChangeLog NEWS README doc/Tips_and_Tricks.txt
+ newdoc src/README README.src
+}