summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2006-12-02 00:04:08 +0000
committerAlec Warner <antarus@gentoo.org>2006-12-02 00:04:08 +0000
commit52c636ebec1f719f384ba6b8b643ffad72d94adf (patch)
tree1f379939c5f014159b880e9fbf8b93e395de0a8b /net-analyzer/tptest/tptest-3.1.7.ebuild
parentAdd x11-libs/libXmu to DEPEND, thanks to Patrick Lauer for reporting, bug 152531 (diff)
downloadgentoo-2-52c636ebec1f719f384ba6b8b643ffad72d94adf.tar.gz
gentoo-2-52c636ebec1f719f384ba6b8b643ffad72d94adf.tar.bz2
gentoo-2-52c636ebec1f719f384ba6b8b643ffad72d94adf.zip
bump for bug # 152549, thanks to Anders Hellgren
(Portage version: 2.1.2_pre3-r9)
Diffstat (limited to 'net-analyzer/tptest/tptest-3.1.7.ebuild')
-rw-r--r--net-analyzer/tptest/tptest-3.1.7.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-analyzer/tptest/tptest-3.1.7.ebuild b/net-analyzer/tptest/tptest-3.1.7.ebuild
new file mode 100644
index 000000000000..e7b0c7d322e5
--- /dev/null
+++ b/net-analyzer/tptest/tptest-3.1.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tptest/tptest-3.1.7.ebuild,v 1.1 2006/12/02 00:04:08 antarus Exp $
+
+DESCRIPTION="Internet bandwidth tester"
+HOMEPAGE="http://tptest.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE=""
+DEPEND=">=sys-apps/sed-4"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/apps/unix/server
+ sed -i "s:^CFLAGS\(.*\):CFLAGS\1 ${CFLAGS} :g" Makefile
+
+ cd ${S}/apps/unix/client
+ sed -i "s:^CFLAGS\(.*\):CFLAGS\1 ${CFLAGS} :g" Makefile
+ cp -f ${S}/os-dep/unix/* .
+ cp -f ${S}/engine/* .
+}
+
+src_compile() {
+ cd ${S}/apps/unix/server
+ emake || die
+
+ cd ${S}/apps/unix/client
+ emake || die
+}
+
+src_install() {
+ dobin ${S}/apps/unix/client/tptestclient
+ dosbin ${S}/apps/unix/server/tptestserver
+
+ insinto /etc
+ doins ${S}/apps/unix/server/tptest.conf
+}