summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-06 08:54:31 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-06 08:54:31 +0000
commit455175567b35676f5c52e4f6d8f3699c1f0f14b7 (patch)
treed401fdc65329f39eec36ddb81d6927b1695d2d08 /net-analyzer/tsung/tsung-1.4.2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-455175567b35676f5c52e4f6d8f3699c1f0f14b7.tar.gz
gentoo-2-455175567b35676f5c52e4f6d8f3699c1f0f14b7.tar.bz2
gentoo-2-455175567b35676f5c52e4f6d8f3699c1f0f14b7.zip
Bump, restrict tests
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/tsung/tsung-1.4.2.ebuild')
-rw-r--r--net-analyzer/tsung/tsung-1.4.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/tsung/tsung-1.4.2.ebuild b/net-analyzer/tsung/tsung-1.4.2.ebuild
new file mode 100644
index 000000000000..f5f620e1227a
--- /dev/null
+++ b/net-analyzer/tsung/tsung-1.4.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tsung/tsung-1.4.2.ebuild,v 1.1 2012/03/06 08:54:31 patrick Exp $
+
+EAPI="3"
+
+# Seems to be misconfigured
+RESTRICT="test"
+
+inherit eutils
+
+DESCRIPTION="Erlang's multi-protocol distributed load testing tool"
+HOMEPAGE="http://tsung.erlang-projects.org/"
+SRC_URI="http://tsung.erlang-projects.org/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/erlang"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ ./configure --prefix="/usr" || die "econf failed"
+}
+
+src_compile() {
+ emake || die "Failed building"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "Failed installing"
+}