summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-01-21 19:05:26 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-01-21 19:05:26 +0000
commit638ad478f902da9e366f73456bb2905eb9aa8cb9 (patch)
tree7df5101be40dc055d85887373a2096e60390e563 /net-analyzer/vnstat/vnstat-1.4.ebuild
parentStable on ppc; bug #78712. (diff)
downloadgentoo-2-638ad478f902da9e366f73456bb2905eb9aa8cb9.tar.gz
gentoo-2-638ad478f902da9e366f73456bb2905eb9aa8cb9.tar.bz2
gentoo-2-638ad478f902da9e366f73456bb2905eb9aa8cb9.zip
Install cron script in /etc/cron.hourly where it belongs, as /etc/cron.d 1) is only supported by vixie, and 2) should contain system crontab entries, not bash scripts. Fixes bug 60711.
(Portage version: 2.0.51-r14)
Diffstat (limited to 'net-analyzer/vnstat/vnstat-1.4.ebuild')
-rw-r--r--net-analyzer/vnstat/vnstat-1.4.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/net-analyzer/vnstat/vnstat-1.4.ebuild b/net-analyzer/vnstat/vnstat-1.4.ebuild
index 755c070d4708..7943a52ec95a 100644
--- a/net-analyzer/vnstat/vnstat-1.4.ebuild
+++ b/net-analyzer/vnstat/vnstat-1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/vnstat/vnstat-1.4.ebuild,v 1.8 2004/09/29 02:58:04 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/vnstat/vnstat-1.4.ebuild,v 1.9 2005/01/21 19:05:26 ka0ttic Exp $
DESCRIPTION="Console-based network traffic monitor that keeps statistics of network usage"
HOMEPAGE="http://humdi.net/vnstat/"
@@ -21,8 +21,8 @@ src_install() {
keepdir /var/lib/vnstat
dobin src/vnstat || die
- exeinto /etc/cron.d
- newexe ${FILESDIR}/vnstat.cron vnstat
+ exeinto /etc/cron.hourly
+ doexe ${FILESDIR}/vnstat.cron vnstat
doman man/vnstat.1
newdoc pppd/vnstat_ip-down ip-down.example
@@ -32,7 +32,7 @@ src_install() {
pkg_postinst() {
# compatibility for 1.1 ebuild
- if [ -d ${ROOT}/var/spool/vnstat ] ; then
+ if [[ -d ${ROOT}/var/spool/vnstat ]] ; then
mv -f ${ROOT}/var/spool/vnstat/* ${ROOT}/var/lib/vnstat \
&& rmdir ${ROOT}/var/spool/vnstat
einfo "vnStat db files moved from /var/spool/vnstat to /var/lib/vnstat"
@@ -41,7 +41,17 @@ pkg_postinst() {
einfo "Repeat the following command for every interface you"
einfo "wish to monitor (replace eth0):"
einfo " vnstat -u -i eth0"
-
+ einfo
einfo "Note: if an interface transfers more than ~4GB in"
einfo "the time between cron runs, you may miss traffic"
+ einfo
+
+ if [[ -e ${ROOT}/etc/cron.d/vnstat ]] ; then
+ einfo "vnstat\'s cron script is now installed as /etc/cron.hourly/vnstat."
+ einfo "Please remove /etc/cron.d/vnstat."
+ else
+ einfo "A cron script has been installed to /etc/cron.hourly/vnstat."
+ fi
+ einfo "To update your interface database automatically with"
+ einfo "cron, uncomment the lines in /etc/cron.hourly/vnstat."
}