summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-02-20 03:39:14 +0000
committerTim Harder <radhermit@gentoo.org>2013-02-20 03:39:14 +0000
commit040f7c35775b25c532188edf92d1804b39623bad (patch)
tree4b5bad8bca4963ef644f9191da22b60cc1266f7f /net-analyzer
parentmask net-misc/teamviewer for hardened/linux/amd64/no-multilib (diff)
downloadgentoo-2-040f7c35775b25c532188edf92d1804b39623bad.tar.gz
gentoo-2-040f7c35775b25c532188edf92d1804b39623bad.tar.bz2
gentoo-2-040f7c35775b25c532188edf92d1804b39623bad.zip
Version bump.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/httping/ChangeLog7
-rw-r--r--net-analyzer/httping/httping-1.5.8.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 882b21d3eb9b..2432e11eafe5 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.90 2013/01/12 02:04:27 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.91 2013/02/20 03:39:14 radhermit Exp $
+
+*httping-1.5.8 (20 Feb 2013)
+
+ 20 Feb 2013; Tim Harder <radhermit@gentoo.org> +httping-1.5.8.ebuild:
+ Version bump.
*httping-1.5.7 (12 Jan 2013)
diff --git a/net-analyzer/httping/httping-1.5.8.ebuild b/net-analyzer/httping/httping-1.5.8.ebuild
new file mode 100644
index 000000000000..3ea716f099c2
--- /dev/null
+++ b/net-analyzer/httping/httping-1.5.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.5.8.ebuild,v 1.1 2013/02/20 03:39:14 radhermit Exp $
+
+EAPI=5
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug ssl"
+
+RDEPEND="
+ >=sys-libs/ncurses-5
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}"
+
+# This would bring in test? ( dev-util/cppcheck ) but unlike
+# upstream we should only care about compile/run time testing
+RESTRICT="test"
+
+src_prepare() {
+ sed -i "/^OFLAGS/d" Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ SSL=$(usex ssl) \
+ DEBUG=$(usex debug)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+ dodoc readme.txt
+}