summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2011-02-13 23:17:49 +0000
committerMichael Januszewski <spock@gentoo.org>2011-02-13 23:17:49 +0000
commit136d5309745bfdd731cef9523e016c48d3738e0c (patch)
treebc0e1b834cd1a777890e8605443ca7a789e0f23b /net-analyzer
parentUnmask bluray USE flag on mplayer (diff)
downloadgentoo-2-136d5309745bfdd731cef9523e016c48d3738e0c.tar.gz
gentoo-2-136d5309745bfdd731cef9523e016c48d3738e0c.tar.bz2
gentoo-2-136d5309745bfdd731cef9523e016c48d3738e0c.zip
Version bump (bug #353095).
(Portage version: 2.1.9.39/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/ChangeLog9
-rw-r--r--net-analyzer/nmap/nmap-5.51.ebuild58
2 files changed, 65 insertions, 2 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 289d44e076e5..9a6b243a0c8b 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.239 2010/11/15 16:34:31 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.240 2011/02/13 23:17:49 spock Exp $
+
+*nmap-5.51 (13 Feb 2011)
+
+ 13 Feb 2011; Michał Januszewski <spock@gentoo.org> +nmap-5.51.ebuild:
+ Version bump (bug #353095).
15 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
nmap-5.21-r1.ebuild, nmap-5.35.ebuild:
diff --git a/net-analyzer/nmap/nmap-5.51.ebuild b/net-analyzer/nmap/nmap-5.51.ebuild
new file mode 100644
index 000000000000..dbf69902dad7
--- /dev/null
+++ b/net-analyzer/nmap/nmap-5.51.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-5.51.ebuild,v 1.1 2011/02/13 23:17:49 spock Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit eutils flag-o-matic python
+
+MY_P=${P/_beta/BETA}
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="http://nmap.org/dist/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="gtk lua ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 )
+ )
+ lua? ( >=dev-lang/lua-5.1.4-r1[deprecated] )
+ ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.75-include.patch
+ epatch "${FILESDIR}"/${PN}-4.75-nolua.patch
+ epatch "${FILESDIR}"/${PN}-5.10_beta1-string.patch
+ epatch "${FILESDIR}"/${PN}-5.21-python.patch
+ sed -i -e 's/-m 755 -s ncat/-m 755 ncat/' ncat/Makefile.in
+}
+
+src_configure() {
+ # The bundled libdnet is incompatible with the version available in the
+ # tree, so we cannot use the system library here.
+ econf --with-libdnet=included \
+ $(use_with gtk zenmap) \
+ $(use_with lua liblua) \
+ $(use_with ssl openssl)
+}
+
+src_install() {
+ LC_ALL=C emake DESTDIR="${D}" -j1 STRIP=: nmapdatadir="${EPREFIX}"/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}