summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2013-07-01 13:44:47 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2013-07-01 13:44:47 +0000
commit1927c2ded194577556901e3263dd1a35b7e6c418 (patch)
treef569b493d2b0bd1e1295415196687d093c5d49d8 /net-analyzer
parentremove old (diff)
downloadgentoo-2-1927c2ded194577556901e3263dd1a35b7e6c418.tar.gz
gentoo-2-1927c2ded194577556901e3263dd1a35b7e6c418.tar.bz2
gentoo-2-1927c2ded194577556901e3263dd1a35b7e6c418.zip
Fix endianness issues and keyword for mips.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/dhcpdump/ChangeLog9
-rw-r--r--net-analyzer/dhcpdump/dhcpdump-1.8.ebuild7
-rw-r--r--net-analyzer/dhcpdump/files/dhcpdump-1.8-endianness.patch13
3 files changed, 23 insertions, 6 deletions
diff --git a/net-analyzer/dhcpdump/ChangeLog b/net-analyzer/dhcpdump/ChangeLog
index 3653f3000c69..0722a389a469 100644
--- a/net-analyzer/dhcpdump/ChangeLog
+++ b/net-analyzer/dhcpdump/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/dhcpdump
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcpdump/ChangeLog,v 1.6 2011/07/21 01:50:53 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcpdump/ChangeLog,v 1.7 2013/07/01 13:44:47 zx2c4 Exp $
+
+ 01 Jul 2013; Jason A. Donenfeld <zx2c4@gentoo.org>
+ +files/dhcpdump-1.8-endianness.patch, dhcpdump-1.8.ebuild:
+ Fix endianness issues and keyword for mips.
21 Jul 2011; Jeroen Roovers <jer@gentoo.org> dhcpdump-1.8.ebuild:
Add pod2man dependency.
@@ -27,4 +31,3 @@
26 Aug 2007; Thilo Bangert <bangert@gentoo.org> +metadata.xml,
+dhcpdump-1.7.ebuild:
initial import - thanks Adam Carheden - bug #121895
-
diff --git a/net-analyzer/dhcpdump/dhcpdump-1.8.ebuild b/net-analyzer/dhcpdump/dhcpdump-1.8.ebuild
index de964086537c..5d3404460708 100644
--- a/net-analyzer/dhcpdump/dhcpdump-1.8.ebuild
+++ b/net-analyzer/dhcpdump/dhcpdump-1.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcpdump/dhcpdump-1.8.ebuild,v 1.2 2011/07/21 01:50:53 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dhcpdump/dhcpdump-1.8.ebuild,v 1.3 2013/07/01 13:44:47 zx2c4 Exp $
inherit eutils toolchain-funcs
@@ -10,7 +10,7 @@ SRC_URI="http://www.mavetju.org/download/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~x86 ~amd64 ~mips"
IUSE=""
CDEPEND="net-libs/libpcap"
@@ -22,6 +22,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-Makefile.patch
epatch "${FILESDIR}"/${P}-debian.patch
+ epatch "${FILESDIR}"/${P}-endianness.patch
}
src_compile() {
diff --git a/net-analyzer/dhcpdump/files/dhcpdump-1.8-endianness.patch b/net-analyzer/dhcpdump/files/dhcpdump-1.8-endianness.patch
new file mode 100644
index 000000000000..c0dc2f6a9467
--- /dev/null
+++ b/net-analyzer/dhcpdump/files/dhcpdump-1.8-endianness.patch
@@ -0,0 +1,13 @@
+diff -ru dhcpdump-1.8/dhcpdump.c dhcpdump-1.8-modified/dhcpdump.c
+--- dhcpdump-1.8/dhcpdump.c 2008-06-24 05:26:52.000000000 +0200
++++ dhcpdump-1.8-modified/dhcpdump.c 2013-07-01 15:31:04.260609883 +0200
+@@ -130,7 +130,7 @@
+ offset += ETHER_HDR_LEN;
+
+ // Check for IPv4 packets
+- if (eh->ether_type != 8) {
++ if (eh->ether_type != htons(0x0800)) {
+ printf("Ignored non IPv4 packet: %d\n", eh->ether_type);
+ return;
+ }
+