summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-10-23 12:20:35 +0000
committerJeroen Roovers <jer@gentoo.org>2012-10-23 12:20:35 +0000
commit501c696c2a10a037e06338294db5dd4ab64cd46c (patch)
treee4a8bc672145155bb4158000694eb2e369c6b983 /net-analyzer
parentVersion bump, updated translations and code cleanups (diff)
downloadgentoo-2-501c696c2a10a037e06338294db5dd4ab64cd46c.tar.gz
gentoo-2-501c696c2a10a037e06338294db5dd4ab64cd46c.tar.bz2
gentoo-2-501c696c2a10a037e06338294db5dd4ab64cd46c.zip
Version bump.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/httping/ChangeLog8
-rw-r--r--net-analyzer/httping/httping-1.5.2.ebuild37
-rw-r--r--net-analyzer/httping/httping-1.5.5.ebuild42
3 files changed, 49 insertions, 38 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 2f89a778f26c..b1dc60063591 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.81 2012/09/07 21:41:21 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.82 2012/10/23 12:20:35 jer Exp $
+
+*httping-1.5.5 (23 Oct 2012)
+
+ 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> -httping-1.5.2.ebuild,
+ +httping-1.5.5.ebuild:
+ Version bump.
*httping-1.5.4 (07 Sep 2012)
diff --git a/net-analyzer/httping/httping-1.5.2.ebuild b/net-analyzer/httping/httping-1.5.2.ebuild
deleted file mode 100644
index e5e5faa6680c..000000000000
--- a/net-analyzer/httping/httping-1.5.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.5.2.ebuild,v 1.5 2012/03/02 21:22:53 ranger Exp $
-
-EAPI="4"
-
-inherit flag-o-matic toolchain-funcs
-
-MY_P="${P/_beta1/beta}"
-
-DESCRIPTION="http protocol ping-like program"
-HOMEPAGE="http://www.vanheusden.com/httping/"
-SRC_URI="http://www.vanheusden.com/${PN}/${MY_P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa ~mips ~ppc ppc64 ~sparc x86"
-IUSE="debug ssl"
-
-RDEPEND=">=sys-libs/ncurses-5
- ssl? ( dev-libs/openssl )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- $(use ssl && echo SSL=yes || echo SSL=no) \
- $(use debug && echo DEBUG=yes || echo DEBUG=no)
-}
-
-src_install() {
- dobin httping
- doman httping.1
- dodoc readme.txt
-}
diff --git a/net-analyzer/httping/httping-1.5.5.ebuild b/net-analyzer/httping/httping-1.5.5.ebuild
new file mode 100644
index 000000000000..f82bbf24a457
--- /dev/null
+++ b/net-analyzer/httping/httping-1.5.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.5.5.ebuild,v 1.1 2012/10/23 12:20:35 jer Exp $
+
+EAPI=4
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug ssl"
+
+RDEPEND="
+ >=sys-libs/ncurses-5
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}"
+
+# This would bring in test? ( dev-util/cppcheck ) but unlike
+# upstream we should only care about compile/run time testing
+RESTRICT="test"
+
+src_prepare() {
+ sed -i "/^OFLAGS/d" Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ SSL=$(usex ssl) \
+ DEBUG=$(usex debug)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+ dodoc readme.txt
+}