summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-04-30 15:25:17 +0000
committerJeroen Roovers <jer@gentoo.org>2012-04-30 15:25:17 +0000
commitb9728f2eb467c1cc14c22411f77f2abf632908b7 (patch)
treed9d3bb2412e35668cb5bcfea7dc30a5c5378dac7 /net-analyzer
parentmark fx-10.0.4 stable per ago, remove fx-11.0-r1 (diff)
downloadgentoo-2-b9728f2eb467c1cc14c22411f77f2abf632908b7.tar.gz
gentoo-2-b9728f2eb467c1cc14c22411f77f2abf632908b7.tar.bz2
gentoo-2-b9728f2eb467c1cc14c22411f77f2abf632908b7.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sguil-server/ChangeLog9
-rw-r--r--net-analyzer/sguil-server/sguil-server-0.8.0.ebuild101
2 files changed, 108 insertions, 2 deletions
diff --git a/net-analyzer/sguil-server/ChangeLog b/net-analyzer/sguil-server/ChangeLog
index 4a74546731dd..b23b087062d5 100644
--- a/net-analyzer/sguil-server/ChangeLog
+++ b/net-analyzer/sguil-server/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/sguil-server
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sguil-server/ChangeLog,v 1.9 2009/03/08 02:33:01 cla Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sguil-server/ChangeLog,v 1.10 2012/04/30 15:25:17 jer Exp $
+
+*sguil-server-0.8.0 (30 Apr 2012)
+
+ 30 Apr 2012; Jeroen Roovers <jer@gentoo.org> +sguil-server-0.8.0.ebuild:
+ Version bump.
08 Mar 2009; Dawid Węgliński <cla@gentoo.org>
sguil-server-0.6.1-r1.ebuild:
diff --git a/net-analyzer/sguil-server/sguil-server-0.8.0.ebuild b/net-analyzer/sguil-server/sguil-server-0.8.0.ebuild
new file mode 100644
index 000000000000..0031f65c2faa
--- /dev/null
+++ b/net-analyzer/sguil-server/sguil-server-0.8.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sguil-server/sguil-server-0.8.0.ebuild,v 1.1 2012/04/30 15:25:17 jer Exp $
+
+EAPI=4
+
+inherit eutils ssl-cert
+
+MY_PV="${PV/_p/p}"
+DESCRIPTION="Daemon for Sguil Network Security Monitoring"
+HOMEPAGE="http://sguil.sourceforge.net"
+SRC_URI="mirror://sourceforge/sguil/sguil-server-${MY_PV}.tar.gz"
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+DEPEND=">=dev-lang/tcl-8.3[-threads]
+ >=dev-tcltk/tclx-8.3
+ dev-tcltk/tcllib
+ dev-tcltk/mysqltcl
+ ssl? ( >=dev-tcltk/tls-1.4.1 )"
+RDEPEND="${DEPEND}
+ net-analyzer/p0f
+ net-analyzer/tcpflow
+ net-misc/openssh"
+
+S="${WORKDIR}/sguil-${MY_PV}"
+
+pkg_setup() {
+ enewgroup sguil
+ enewuser sguil -1 -1 /var/lib/sguil sguil
+}
+
+src_prepare(){
+ sed -i server/sguild.conf \
+ -e 's:DEBUG 2:DEBUG 1:' -e 's:DAEMON 0:DAEMON 1:' \
+ -e 's:SGUILD_LIB_PATH ./lib:SGUILD_LIB_PATH /usr/lib/sguild:g' \
+ -e 's:/sguild_data/rules:/var/lib/sguil/rules:g' \
+ -e 's:/sguild_data/archive:/var/lib/sguil/archive:g' \
+ -e 's:/usr/lib/sguild:/usr/'$(get_libdir)'/sguild:g' \
+ || die "sed failed"
+ sed -i sguild \
+ -e 's:set VERSION "SGUIL-0.6.0":set VERSION "SGUIL-0.6.0p1":' \
+ || die "sed failed"
+}
+
+src_install(){
+ dodoc server/sql_scripts/*
+ dodoc doc/CHANGES doc/OPENSSL.README doc/USAGE doc/INSTALL \
+ doc/TODO doc/sguildb.dia
+
+ insopts -m640
+ insinto /etc/sguil
+ doins server/{sguild.email,sguild.users,sguild.conf,sguild.queries,sguild.access,autocat.conf}
+
+ insinto /usr/$(get_libdir)/sguild
+ doins server/lib/*
+ dobin server/sguild
+ newinitd "${FILESDIR}/sguild.initd" sguild
+ newconfd "${FILESDIR}/sguild.confd" sguild
+
+ if use ssl; then
+ sed -i -e "s/#OPENSSL/OPENSSL/" "${D}/etc/conf.d/sguild"
+ fi
+
+ diropts -g sguil -o sguil
+ keepdir /var/run/sguil \
+ /var/lib/sguil \
+ /var/lib/sguil/archive \
+ /var/lib/sguil/rules
+
+}
+
+pkg_postinst(){
+ if use ssl && ! [ -f "${ROOT}"/etc/sguil/sguild.key ]; then
+ install_cert /etc/sguil/sguild
+ fi
+
+ chown -R sguil:sguil "${ROOT}"/etc/sguil/sguild.*
+ chown -R sguil:sguil "${ROOT}"/usr/lib/sguild
+
+ if [ -d "${ROOT}"/etc/snort/rules ] ; then
+ ln -s /etc/snort/rules "${ROOT}"/var/lib/sguil/rules/${HOSTNAME}
+ fi
+
+ elog
+ elog "Please customize the sguild configuration files in /etc/sguild before"
+ elog "trying to run the daemon. Additionally you will need to setup the"
+ elog "mysql database. See /usr/share/doc/${PF}/INSTALL.gz for information."
+ elog "Please note that it is STRONGLY recommended to mount a separate"
+ elog "filesystem at /var/lib/sguil for both space and performance reasons"
+ elog "as a large amount of data will be kept in the directory structure"
+ elog "underneath that top directory."
+ elog
+ elog "You should create the sguild db as per the install instructions in"
+ elog "/usr/share/doc/${PF}/ and use the appropriate"
+ elog "database setup script located in the same directory."
+
+ elog
+}