summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-12-15 15:00:04 +0000
committerMichael Januszewski <spock@gentoo.org>2007-12-15 15:00:04 +0000
commite157c144d4e969a7c6a938264ab0c530f5d4543b (patch)
treeddc56cf7706f5748fa0c881d35d28cc92aa33170 /net-analyzer
parentFix masking screw-up: the mask should be for nmap-4.50, not 3.50. (diff)
downloadgentoo-2-e157c144d4e969a7c6a938264ab0c530f5d4543b.tar.gz
gentoo-2-e157c144d4e969a7c6a938264ab0c530f5d4543b.tar.bz2
gentoo-2-e157c144d4e969a7c6a938264ab0c530f5d4543b.zip
Version bump (bug #202209).
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/ChangeLog7
-rw-r--r--net-analyzer/nmap/files/digest-nmap-4.503
-rw-r--r--net-analyzer/nmap/nmap-4.20.ebuild4
-rw-r--r--net-analyzer/nmap/nmap-4.50.ebuild37
4 files changed, 48 insertions, 3 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 6bf69cae0d09..9778e43e40c5 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.147 2007/09/07 23:19:50 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.148 2007/12/15 15:00:04 spock Exp $
+
+*nmap-4.50 (15 Dec 2007)
+
+ 15 Dec 2007; Michał Januszewski <spock@gentoo.org> +nmap-4.50.ebuild:
+ Version bump (bug #202209).
07 Sep 2007; Michał Januszewski <spock@gentoo.org> -nmap-4.11.ebuild:
Remove an old ebuild.
diff --git a/net-analyzer/nmap/files/digest-nmap-4.50 b/net-analyzer/nmap/files/digest-nmap-4.50
new file mode 100644
index 000000000000..516a09d62a6d
--- /dev/null
+++ b/net-analyzer/nmap/files/digest-nmap-4.50
@@ -0,0 +1,3 @@
+MD5 9dabb008923641ffb51aa21f72e6f54a nmap-4.50.tar.bz2 3128562
+RMD160 188f93b817185ee1c131e6bb3eeafce5edd02acd nmap-4.50.tar.bz2 3128562
+SHA256 4760ccdab5894e129c9d1339817684dc8b1416aec48e556ef844c7c55731f8e5 nmap-4.50.tar.bz2 3128562
diff --git a/net-analyzer/nmap/nmap-4.20.ebuild b/net-analyzer/nmap/nmap-4.20.ebuild
index 89fcc16d4078..d010e9d4d777 100644
--- a/net-analyzer/nmap/nmap-4.20.ebuild
+++ b/net-analyzer/nmap/nmap-4.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.20.ebuild,v 1.15 2007/09/07 23:16:58 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.20.ebuild,v 1.16 2007/12/15 15:00:04 spock Exp $
inherit eutils flag-o-matic
@@ -38,7 +38,7 @@ src_compile() {
}
src_install() {
- einstall -j1 nmapdatadir=${D}/usr/share/nmap install || die
+ einstall -j1 nmapdatadir="${D}/usr/share/nmap" install || die
dodoc CHANGELOG HACKING docs/README docs/*.txt || die
use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
diff --git a/net-analyzer/nmap/nmap-4.50.ebuild b/net-analyzer/nmap/nmap-4.50.ebuild
new file mode 100644
index 000000000000..f6b1db7c0eab
--- /dev/null
+++ b/net-analyzer/nmap/nmap-4.50.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.50.ebuild,v 1.1 2007/12/15 15:00:04 spock Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://www.insecure.org/nmap/"
+SRC_URI="http://download.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ >=dev-python/pysqlite-2 )
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ use ppc-macos && filter-flags -fstrict-aliasing -O2
+ econf \
+ --with-libdnet=included \
+ $(use_with gtk zenmap) \
+ $(use_with ssl openssl) || die
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" -j1 nmapdatadir=/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}