summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-09-16 21:35:14 +0000
committerAlin Năstac <mrness@gentoo.org>2009-09-16 21:35:14 +0000
commitd886f8a9e6274e681773fc3b402bbfe86ad64133 (patch)
tree76fc1aaf5dd5e21a60dbe1d8d44448744f378a68 /net-dialup/pptpclient
parentVersion bump (diff)
downloadgentoo-2-d886f8a9e6274e681773fc3b402bbfe86ad64133.tar.gz
gentoo-2-d886f8a9e6274e681773fc3b402bbfe86ad64133.tar.bz2
gentoo-2-d886f8a9e6274e681773fc3b402bbfe86ad64133.zip
Fix wrong hardcoded path to ip utility (#284460).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-dialup/pptpclient')
-rw-r--r--net-dialup/pptpclient/ChangeLog9
-rw-r--r--net-dialup/pptpclient/files/pptpclient-1.7.2-ip-path.patch29
-rw-r--r--net-dialup/pptpclient/pptpclient-1.7.2-r1.ebuild (renamed from net-dialup/pptpclient/pptpclient-1.7.2.ebuild)5
3 files changed, 40 insertions, 3 deletions
diff --git a/net-dialup/pptpclient/ChangeLog b/net-dialup/pptpclient/ChangeLog
index aff3dc58e01a..5f3d9965121f 100644
--- a/net-dialup/pptpclient/ChangeLog
+++ b/net-dialup/pptpclient/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/pptpclient
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/ChangeLog,v 1.49 2009/06/20 09:00:49 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/ChangeLog,v 1.50 2009/09/16 21:35:13 mrness Exp $
+
+*pptpclient-1.7.2-r1 (16 Sep 2009)
+
+ 16 Sep 2009; Alin Năstac <mrness@gentoo.org>
+ +files/pptpclient-1.7.2-ip-path.patch, -pptpclient-1.7.2.ebuild,
+ +pptpclient-1.7.2-r1.ebuild:
+ Fix wrong hardcoded path to ip utility (#284460).
*pptpclient-1.7.2 (20 Jun 2009)
diff --git a/net-dialup/pptpclient/files/pptpclient-1.7.2-ip-path.patch b/net-dialup/pptpclient/files/pptpclient-1.7.2-ip-path.patch
new file mode 100644
index 000000000000..0e5902113f47
--- /dev/null
+++ b/net-dialup/pptpclient/files/pptpclient-1.7.2-ip-path.patch
@@ -0,0 +1,29 @@
+diff -Nru pptp-1.7.2.orig/routing.c pptp-1.7.2/routing.c
+--- pptp-1.7.2.orig/routing.c 2008-05-14 08:33:55.000000000 +0200
++++ pptp-1.7.2/routing.c 2009-09-16 23:28:11.000000000 +0200
+@@ -55,7 +55,7 @@
+
+ void routing_init(char *ip) {
+ char buf[256];
+- snprintf(buf, 255, "/bin/ip route get %s", ip);
++ snprintf(buf, 255, "/sbin/ip route get %s", ip);
+ FILE *p = popen(buf, "r");
+ fgets(buf, 255, p);
+ /* TODO: check for failure of fgets */
+@@ -66,14 +66,14 @@
+
+ void routing_start() {
+ char buf[256];
+- snprintf(buf, 255, "/bin/ip route replace %s", route);
++ snprintf(buf, 255, "/sbin/ip route replace %s", route);
+ FILE *p = popen(buf, "r");
+ pclose(p);
+ }
+
+ void routing_end() {
+ char buf[256];
+- snprintf(buf, 255, "/bin/ip route delete %s", route);
++ snprintf(buf, 255, "/sbin/ip route delete %s", route);
+ FILE *p = popen(buf, "r");
+ pclose(p);
+ }
diff --git a/net-dialup/pptpclient/pptpclient-1.7.2.ebuild b/net-dialup/pptpclient/pptpclient-1.7.2-r1.ebuild
index a53ad4d3fcd6..b0aea06f946d 100644
--- a/net-dialup/pptpclient/pptpclient-1.7.2.ebuild
+++ b/net-dialup/pptpclient/pptpclient-1.7.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/pptpclient-1.7.2.ebuild,v 1.1 2009/06/20 09:00:49 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pptpclient/pptpclient-1.7.2-r1.ebuild,v 1.1 2009/09/16 21:35:13 mrness Exp $
EAPI="2"
@@ -19,7 +19,7 @@ LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
IUSE="tk"
-DEPEND=">=net-dialup/ppp-2.4.2
+DEPEND="net-dialup/ppp
dev-lang/perl
tk? ( dev-perl/perl-tk )"
RDEPEND="${DEPEND}"
@@ -30,6 +30,7 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch "${FILESDIR}"/${P}-process-name.patch
+ epatch "${FILESDIR}"/${P}-ip-path.patch
}
src_compile() {