summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-07-17 18:19:10 +0000
committerAlin Năstac <mrness@gentoo.org>2008-07-17 18:19:10 +0000
commite6e092b663bd14e0ff96279352c1bb949434ebe9 (patch)
treeb576d0afb827ac53fe77789145516a4c8e525980 /net-dialup/xl2tpd
parentalpha/ia64/sparc stable wrt #231975 (diff)
downloadgentoo-2-e6e092b663bd14e0ff96279352c1bb949434ebe9.tar.gz
gentoo-2-e6e092b663bd14e0ff96279352c1bb949434ebe9.tar.bz2
gentoo-2-e6e092b663bd14e0ff96279352c1bb949434ebe9.zip
Close the PPP daemon gracefully when L2TP connection is ended (#231964).
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-dialup/xl2tpd')
-rw-r--r--net-dialup/xl2tpd/ChangeLog7
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.1.12-r1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/net-dialup/xl2tpd/ChangeLog b/net-dialup/xl2tpd/ChangeLog
index 781a8fbf201e..1c08b1fb8132 100644
--- a/net-dialup/xl2tpd/ChangeLog
+++ b/net-dialup/xl2tpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/xl2tpd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.15 2008/06/08 14:08:40 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.16 2008/07/17 18:19:10 mrness Exp $
+
+*xl2tpd-1.1.12-r1 (17 Jul 2008)
+
+ 17 Jul 2008; Alin Năstac <mrness@gentoo.org> +xl2tpd-1.1.12-r1.ebuild:
+ Close the PPP daemon gracefully when L2TP connection is ended (#231964).
08 Jun 2008; Alin Năstac <mrness@gentoo.org> -xl2tpd-1.1.11.ebuild:
Remove obsolete version.
diff --git a/net-dialup/xl2tpd/xl2tpd-1.1.12-r1.ebuild b/net-dialup/xl2tpd/xl2tpd-1.1.12-r1.ebuild
new file mode 100644
index 000000000000..682484cd4959
--- /dev/null
+++ b/net-dialup/xl2tpd/xl2tpd-1.1.12-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.1.12-r1.ebuild,v 1.1 2008/07/17 18:19:10 mrness Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
+HOMEPAGE="http://www.xelerance.com/software/xl2tpd/"
+SRC_URI="ftp://ftp.xelerance.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!net-dialup/l2tpd
+ net-dialup/ppp"
+
+src_compile() {
+ append-flags -DTRUST_PPPD_TO_DIE
+ emake || die "emake failed"
+}
+
+src_install() {
+ dosbin xl2tpd || die 'xl2tpd binary not found'
+ doman doc/*.[85]
+
+ dodoc CREDITS README.xl2tpd \
+ doc/README.patents doc/rfc2661.txt doc/*.sample
+
+ dodir /etc/xl2tpd
+ head -n 2 doc/l2tp-secrets.sample > "${D}/etc/xl2tpd/l2tp-secrets"
+ fperms 0600 /etc/xl2tpd/l2tp-secrets
+ newinitd "${FILESDIR}/xl2tpd-init" xl2tpd
+
+ keepdir /var/run/xl2tpd
+}