summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2004-12-14 19:45:39 +0000
committerAlin Năstac <mrness@gentoo.org>2004-12-14 19:45:39 +0000
commit208981692964191f522383e0a66da4b5e6178de5 (patch)
treeee2fe82ea7f6c1a76c05f25766bf124af0fa31d5 /net-dialup
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-208981692964191f522383e0a66da4b5e6178de5.tar.gz
gentoo-2-208981692964191f522383e0a66da4b5e6178de5.tar.bz2
gentoo-2-208981692964191f522383e0a66da4b5e6178de5.zip
kernel-mod -> linux-mod
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/gigaset-isdn/ChangeLog5
-rw-r--r--net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild45
2 files changed, 31 insertions, 19 deletions
diff --git a/net-dialup/gigaset-isdn/ChangeLog b/net-dialup/gigaset-isdn/ChangeLog
index d9e179bf9ef0..e36388dbe372 100644
--- a/net-dialup/gigaset-isdn/ChangeLog
+++ b/net-dialup/gigaset-isdn/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-dialup/gigaset-isdn
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/gigaset-isdn/ChangeLog,v 1.2 2004/12/05 21:40:11 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gigaset-isdn/ChangeLog,v 1.3 2004/12/14 19:45:39 mrness Exp $
+
+ 14 Dec 2004; Alin Nastac <mrness@gentoo.org> gigaset-isdn-0.4.0.ebuild:
+ Replaced kernel-mod eclass with linux-mod. See #74399.
05 Dec 2004; Alin Nastac <mrness@gentoo.org> gigaset-isdn-0.4.0.ebuild:
Remove inherit kernel-mod and mark stable on x86.
diff --git a/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild b/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild
index 529a101b8a93..a20044b15ee5 100644
--- a/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild
+++ b/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild,v 1.2 2004/12/05 21:40:11 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gigaset-isdn/gigaset-isdn-0.4.0.ebuild,v 1.3 2004/12/14 19:45:39 mrness Exp $
+
+inherit linux-mod
MY_P=${P/-isdn/}
S=${WORKDIR}/${MY_P}
@@ -14,26 +16,33 @@ SLOT="0"
KEYWORDS="x86"
IUSE="debug"
-src_compile() {
- cd "${S}"
- ./configure --kernel=${KV} --root=${D} --prefix=/usr \
- --with-ring `use_with debug`
-
- (
- unset ARCH
- emake || die "Compilation failed"
- )
+MODULE_NAMES="bas_gigaset(drivers/isdn:) ser_gigaset(drivers/isdn:) usb_gigaset(drivers/isdn:)"
+BUILD_TARGETS="all"
+CONFIG_CHECK="ISDN_I4L"
+ISDN_I4L_ERROR="This driver requires that your kernel is compiled with support for ISDN4Linux (I4L)"
+
+src_unpack() {
+ unpack ${A}
+
+ # Fix broken makefile
+ convert_to_m ${S}/Makefile.26.in
+
+ # We will take care of installing modules, not you
+ sed -i "s:if \[ \$\# -ne 0 \]:if \[ 0 -ne 0 \]:g" ${S}/generic/installfiles
+
+ # We will run depmod, not you
+ sed -i "s:.*generic/post.*::g" ${S}/generic/install
}
-src_install () {
- cd "${S}"
- #Disable depmod while in sandbox
- sed -i -e 's:.*depmod :#&:' generic/post
- einstall ROOT=${D} || die "Failed to install drivers"
+src_compile() {
+ ./configure --kernel=${KV_FULL} --kerneldir=${KV_DIR} --root=${D} --prefix=/usr \
+ --with-ring $(use_with debug)
- dodoc README Release.notes TODO known_bugs.txt
+ linux-mod_src_compile
}
-pkg_postinst () {
- depmod -ae ${KV}
+src_install () {
+ linux-mod_src_install
+ einstall ROOT=${D} || die "Failed to install frontend"
+ dodoc README Release.notes TODO known_bugs.txt
}