summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-12-26 00:53:01 +0000
committerMike Gilbert <floppym@gentoo.org>2012-12-26 00:53:01 +0000
commit26050e5d3716c547e4aa54262a070d9fe2ad33ff (patch)
tree2986b05b778913e3cc838a42a31a4ea52acbba3d /net-dialup
parentVersion bump for Gnome 3.6. (diff)
downloadgentoo-2-26050e5d3716c547e4aa54262a070d9fe2ad33ff.tar.gz
gentoo-2-26050e5d3716c547e4aa54262a070d9fe2ad33ff.tar.bz2
gentoo-2-26050e5d3716c547e4aa54262a070d9fe2ad33ff.zip
Fix sed.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/xl2tpd/ChangeLog6
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.1-r1.ebuild4
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.1.ebuild46
3 files changed, 7 insertions, 49 deletions
diff --git a/net-dialup/xl2tpd/ChangeLog b/net-dialup/xl2tpd/ChangeLog
index f85b7d059070..7c3bd4ed7a57 100644
--- a/net-dialup/xl2tpd/ChangeLog
+++ b/net-dialup/xl2tpd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/xl2tpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.32 2012/12/25 21:10:05 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/ChangeLog,v 1.33 2012/12/26 00:53:01 floppym Exp $
+
+ 26 Dec 2012; Mike Gilbert <floppym@gentoo.org> -xl2tpd-1.3.1.ebuild,
+ xl2tpd-1.3.1-r1.ebuild:
+ Fix sed.
25 Dec 2012; Mike Gilbert <floppym@gentoo.org>
+files/xl2tpd-1.3.1-CFLAGS.patch, xl2tpd-1.3.1-r1.ebuild:
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.1-r1.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.1-r1.ebuild
index 9369efc1271c..1c8af472cd74 100644
--- a/net-dialup/xl2tpd/xl2tpd-1.3.1-r1.ebuild
+++ b/net-dialup/xl2tpd/xl2tpd-1.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.3.1-r1.ebuild,v 1.2 2012/12/25 21:10:05 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.3.1-r1.ebuild,v 1.3 2012/12/26 00:53:01 floppym Exp $
EAPI="4"
@@ -24,7 +24,7 @@ S="${WORKDIR}/xelerance-${PN}-95445fc"
src_prepare() {
epatch "${FILESDIR}/${PN}-1.3.0-LDFLAGS.patch"
epatch "${FILESDIR}/${PN}-1.3.1-CFLAGS.patch"
- sed -i Makefile -e 's| -O2 ||g' || die "sed Makefile"
+ sed -i Makefile -e 's| -O2||g' || die "sed Makefile"
# The below patch is questionable. Why wasn't it submitted upstream? If it
# ever breaks, it will just be removed. -darkside 20120914
use dnsretry && epatch "${FILESDIR}/${PN}-dnsretry.patch"
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.1.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.1.ebuild
deleted file mode 100644
index d3405dc5a675..000000000000
--- a/net-dialup/xl2tpd/xl2tpd-1.3.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/xl2tpd/xl2tpd-1.3.1.ebuild,v 1.2 2012/09/14 20:34:25 darkside Exp $
-
-EAPI="4"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A modern version of the Layer 2 Tunneling Protocol (L2TP) daemon"
-HOMEPAGE="http://www.xelerance.com/services/software/xl2tpd/"
-SRC_URI="https://github.com/xelerance/${PN}/tarball/v${PV} -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="dnsretry"
-
-DEPEND="net-libs/libpcap"
-RDEPEND="${DEPEND}
- net-dialup/ppp"
-
-S="${WORKDIR}/xelerance-${PN}-95445fc"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.3.0-LDFLAGS.patch"
- sed -i Makefile -e 's| -O2 ||g' || die "sed Makefile"
- # The below patch is questionable. Why wasn't it submitted upstream? If it
- # ever breaks, it will just be removed. -darkside 20120914
- use dnsretry && epatch "${FILESDIR}/${PN}-dnsretry.patch"
-}
-
-src_compile() {
- emake CC=$(tc-getCC)
-}
-
-src_install() {
- emake PREFIX=/usr DESTDIR="${D}" install
-
- dodoc CREDITS README.xl2tpd BUGS CHANGES TODO doc/README.patents doc/rfc2661.txt
-
- dodir /etc/xl2tpd
- cp doc/l2tp-secrets.sample "${ED}/etc/xl2tpd/l2tp-secrets" || die
- cp doc/l2tpd.conf.sample "${ED}/etc/xl2tpd/xl2tpd.conf" || die
- fperms 0600 /etc/xl2tpd/l2tp-secrets
- newinitd "${FILESDIR}"/xl2tpd-init-r1 xl2tpd
-}