summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-01-06 03:10:37 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-01-06 03:10:37 +0000
commit191dada5396ee00a5870e7319e49270b4cabee4e (patch)
tree946914da09008886192944b8f51b454294be31a1 /net-dns/maradns/maradns-1.2.12.09.ebuild
parentversion bump (diff)
downloadgentoo-2-191dada5396ee00a5870e7319e49270b4cabee4e.tar.gz
gentoo-2-191dada5396ee00a5870e7319e49270b4cabee4e.tar.bz2
gentoo-2-191dada5396ee00a5870e7319e49270b4cabee4e.zip
Fixed #192328 and #204351.
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-dns/maradns/maradns-1.2.12.09.ebuild')
-rw-r--r--net-dns/maradns/maradns-1.2.12.09.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-dns/maradns/maradns-1.2.12.09.ebuild b/net-dns/maradns/maradns-1.2.12.09.ebuild
new file mode 100644
index 000000000000..3bb8eb30e2ad
--- /dev/null
+++ b/net-dns/maradns/maradns-1.2.12.09.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/maradns/maradns-1.2.12.09.ebuild,v 1.1 2008/01/06 03:10:36 matsuu Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Proxy DNS server with permanent caching"
+HOMEPAGE="http://www.maradns.org/"
+SRC_URI="mirror://sourceforge/maradns/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:PREFIX/man:PREFIX/share/man:" \
+ -e "s:PREFIX/doc/maradns-\$VERSION:PREFIX/share/doc/${PF}:" \
+ build/install.locations || die
+ sed -i -e "s:-O2:${CFLAGS}:" build/Makefile.linux || die
+}
+
+src_compile() {
+ ./configure || die
+ emake CC="$(tc-getCC)" || die "compile problem"
+}
+
+src_install() {
+ dosbin server/maradns
+ # use authonly && newsbin server/maradns.authonly maradns
+ dosbin tcp/zoneserver
+
+ dobin tcp/getzone tcp/fetchzone tools/askmara tools/duende
+
+ doman doc/en/man/*.[1-9]
+
+ dodoc maradns.gpg.key
+ dodoc doc/en/{QuickStart,README,*.txt}
+ dohtml doc/en/*.html
+ dohtml -r doc/en/webpage
+ docinto examples; dodoc doc/en/examples/example_*
+
+ insinto /etc; newins doc/en/examples/example_mararc mararc
+ insinto /etc/maradns; newins doc/en/examples/example_csv2 db.example.net
+ keepdir /etc/maradns/logger
+
+ newinitd "${FILESDIR}"/maradns.rc6 maradns
+ newinitd "${FILESDIR}"/zoneserver.rc6 zoneserver
+}
+
+pkg_postinst() {
+ enewuser maradns 99 -1 /var/empty daemon
+}