summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2014-10-04 17:58:35 +0000
committerMichael Orlitzky <mjo@gentoo.org>2014-10-04 17:58:35 +0000
commitd126ed02851c7ccd631429824f93535dbe8ef191 (patch)
tree3d4d022f21d70d1b793f21673fd652dc2e7cd0dd /net-dns/rbldnsd
parentVersion bump. (diff)
downloadgentoo-2-d126ed02851c7ccd631429824f93535dbe8ef191.tar.gz
gentoo-2-d126ed02851c7ccd631429824f93535dbe8ef191.tar.bz2
gentoo-2-d126ed02851c7ccd631429824f93535dbe8ef191.zip
Revbump to fix bug #520602.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x6F48D3DA05C2DADB!)
Diffstat (limited to 'net-dns/rbldnsd')
-rw-r--r--net-dns/rbldnsd/ChangeLog11
-rw-r--r--net-dns/rbldnsd/files/rbldnsd-0.997a-format-security-compile-fix.patch30
-rw-r--r--net-dns/rbldnsd/rbldnsd-0.997a-r1.ebuild67
3 files changed, 106 insertions, 2 deletions
diff --git a/net-dns/rbldnsd/ChangeLog b/net-dns/rbldnsd/ChangeLog
index 9f85099732b3..9a12b83214b9 100644
--- a/net-dns/rbldnsd/ChangeLog
+++ b/net-dns/rbldnsd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/rbldnsd
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/rbldnsd/ChangeLog,v 1.28 2013/12/12 14:12:35 mjo Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/rbldnsd/ChangeLog,v 1.29 2014/10/04 17:58:35 mjo Exp $
+
+*rbldnsd-0.997a-r1 (04 Oct 2014)
+
+ 04 Oct 2014; Michael Orlitzky <mjo@gentoo.org>
+ +files/rbldnsd-0.997a-format-security-compile-fix.patch,
+ +rbldnsd-0.997a-r1.ebuild:
+ Revbump to fix bug #520602.
12 Dec 2013; Michael Orlitzky <mjo@gentoo.org> rbldnsd-0.997a.ebuild:
Add missing PYTHON_REQUIRED_USE when tests are enabled.
diff --git a/net-dns/rbldnsd/files/rbldnsd-0.997a-format-security-compile-fix.patch b/net-dns/rbldnsd/files/rbldnsd-0.997a-format-security-compile-fix.patch
new file mode 100644
index 000000000000..03da010336e3
--- /dev/null
+++ b/net-dns/rbldnsd/files/rbldnsd-0.997a-format-security-compile-fix.patch
@@ -0,0 +1,30 @@
+From 5d3455065f84fe1ef4673552a27d2e6e8f02c97a Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Mon, 22 Sep 2014 10:09:27 -0400
+Subject: [PATCH 1/1] Fix compilation with -Werror=format-security.
+
+The dslog() function takes an optional format string, analogous to
+e.g. printf(), and a list of arguments to be substituted into the
+format string. A call to dslog() in do_reload() omitted the format
+string causing GCC to throw a format-security warning. To silence the
+warning, a trivial format string of "%s" was provided.
+---
+ rbldnsd.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/rbldnsd.c b/rbldnsd.c
+index abf1d01..e791231 100644
+--- a/rbldnsd.c
++++ b/rbldnsd.c
+@@ -959,7 +959,7 @@ static int do_reload(int do_fork) {
+ # undef kb
+ }
+ #endif /* NO_MEMINFO */
+- dslog(LOG_INFO, 0, ibuf);
++ dslog(LOG_INFO, 0, "%s", ibuf);
+
+ check_expires();
+
+--
+1.8.5.5
+
diff --git a/net-dns/rbldnsd/rbldnsd-0.997a-r1.ebuild b/net-dns/rbldnsd/rbldnsd-0.997a-r1.ebuild
new file mode 100644
index 000000000000..cbf77cbf3658
--- /dev/null
+++ b/net-dns/rbldnsd/rbldnsd-0.997a-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/rbldnsd/rbldnsd-0.997a-r1.ebuild,v 1.1 2014/10/04 17:58:35 mjo Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils toolchain-funcs user python-single-r1
+
+DESCRIPTION="DNS server designed to serve blacklist zones"
+HOMEPAGE="http://www.corpit.ru/mjt/rbldnsd.html"
+SRC_URI="http://www.corpit.ru/mjt/rbldnsd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 test zlib"
+
+REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS}
+ dev-python/pydns:2[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-robust-ipv6-test-support.patch"
+ epatch "${FILESDIR}/${P}-format-security-compile-fix.patch"
+}
+
+src_configure() {
+ # The ./configure file is handwritten and doesn't support a `make
+ # install` target, so there are no --prefix options. The econf
+ # function appends those automatically, so we can't use it.
+ ./configure \
+ $(use_enable ipv6) \
+ $(use_enable zlib) \
+ || die "./configure failed"
+}
+
+src_compile() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ RANLIB="$(tc-getRANLIB)"
+}
+
+src_test() {
+ emake check \
+ CC="$(tc-getCC)" \
+ PYTHON="${PYTHON}"
+}
+
+src_install() {
+ dosbin rbldnsd
+ doman rbldnsd.8
+ keepdir /var/db/rbldnsd
+ dodoc CHANGES* TODO NEWS README*
+ newinitd "${FILESDIR}"/initd-${PV} rbldnsd
+ newconfd "${FILESDIR}"/confd-${PV} rbldnsd
+}
+
+pkg_postinst() {
+ enewgroup rbldns
+ enewuser rbldns -1 -1 /var/db/rbldnsd rbldns
+ chown rbldns:rbldns /var/db/rbldnsd
+}