summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2008-07-21 04:40:14 +0000
committerPatrick McLean <chutzpah@gentoo.org>2008-07-21 04:40:14 +0000
commitc97ee0ada76fc09046a6197f6077051ecdf2dd2e (patch)
treea30fe336a80cf6ac19453369095afb0449942322 /net-dns
parentStable for HPPA (bug #230956). (diff)
downloadgentoo-2-c97ee0ada76fc09046a6197f6077051ecdf2dd2e.tar.gz
gentoo-2-c97ee0ada76fc09046a6197f6077051ecdf2dd2e.tar.bz2
gentoo-2-c97ee0ada76fc09046a6197f6077051ecdf2dd2e.zip
Version bump (bug #232523), clean out some older versions.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsmasq/ChangeLog7
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.45.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/net-dns/dnsmasq/ChangeLog b/net-dns/dnsmasq/ChangeLog
index de85fb11b7ee..5e844139db06 100644
--- a/net-dns/dnsmasq/ChangeLog
+++ b/net-dns/dnsmasq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/dnsmasq
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.165 2008/07/13 17:26:13 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.166 2008/07/21 04:40:14 chutzpah Exp $
+
+*dnsmasq-2.45 (21 Jul 2008)
+
+ 21 Jul 2008; Patrick McLean <chutzpah@gentoo.org> +dnsmasq-2.45.ebuild:
+ Version bump (bug #232523), clean out some older versions.
13 Jul 2008; Tobias Scherbaum <dertobi123@gentoo.org> dnsmasq-2.43.ebuild:
ppc stable, bug #231282
diff --git a/net-dns/dnsmasq/dnsmasq-2.45.ebuild b/net-dns/dnsmasq/dnsmasq-2.45.ebuild
new file mode 100644
index 000000000000..2d3e73d73912
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.45.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.45.ebuild,v 1.1 2008/07/21 04:40:14 chutzpah Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.lzma"
+#SRC_URI="http://www.thekelleys.org.uk/dnsmasq/release-candidates/${MY_P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="dbus ipv6 isc nls tftp"
+
+RDEPEND="dbus? ( sys-apps/dbus )
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND}
+ app-arch/lzma-utils"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i '/^AWK/s:nawk:gawk:' Makefile #214865
+ # dnsmasq on FreeBSD wants the config file in a silly location, this fixes
+ epatch "${FILESDIR}/${PN}-fbsd-config.patch"
+}
+
+src_compile() {
+ use tftp || append-flags -DNO_TFTP
+ use ipv6 || append-flags -DNO_IPV6
+ use isc && append-flags -DHAVE_ISC_READER
+ use dbus && sed -i '$ a #define HAVE_DBUS' src/config.h
+
+ emake \
+ PREFIX=/usr \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ all$(use nls && echo "-i18n") || die
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR="${D}" \
+ install$(use nls && echo "-i18n") || die
+
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/dnsmasq-init dnsmasq
+ newconfd "${FILESDIR}"/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+
+ if use dbus ; then
+ insinto /etc/dbus-1/system.d
+ doins dbus/dnsmasq.conf
+ fi
+}