summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-12-17 19:45:42 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-12-17 19:45:42 +0000
commita45617b45c7089bb464e6a86c1ab9614244fddd5 (patch)
tree9f348f85f073fb7ce10a49913c8a9685326845be /net-firewall/arno-iptables-firewall
parentBump to EAPI=5 to make Paludis happy, bug #447524. (diff)
downloadgentoo-2-a45617b45c7089bb464e6a86c1ab9614244fddd5.tar.gz
gentoo-2-a45617b45c7089bb464e6a86c1ab9614244fddd5.tar.bz2
gentoo-2-a45617b45c7089bb464e6a86c1ab9614244fddd5.zip
Version bump. Fixes 447386. Also fixes outstanding #309473 and #411661. Thanks to Ferenc Erki <erkiferenc@gmail.com>
(Portage version: 2.1.11.37/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'net-firewall/arno-iptables-firewall')
-rw-r--r--net-firewall/arno-iptables-firewall/ChangeLog13
-rw-r--r--net-firewall/arno-iptables-firewall/arno-iptables-firewall-2.0.1d.ebuild101
-rw-r--r--net-firewall/arno-iptables-firewall/files/rc.firewall_replace_opts.patch11
-rw-r--r--net-firewall/arno-iptables-firewall/metadata.xml4
4 files changed, 125 insertions, 4 deletions
diff --git a/net-firewall/arno-iptables-firewall/ChangeLog b/net-firewall/arno-iptables-firewall/ChangeLog
index a4b5b0909cc1..0a4f98db5ff2 100644
--- a/net-firewall/arno-iptables-firewall/ChangeLog
+++ b/net-firewall/arno-iptables-firewall/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-firewall/arno-iptables-firewall
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/arno-iptables-firewall/ChangeLog,v 1.5 2009/10/10 13:28:39 vostorga Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/arno-iptables-firewall/ChangeLog,v 1.6 2012/12/17 19:45:41 hwoarang Exp $
+
+*arno-iptables-firewall-2.0.1d (17 Dec 2012)
+
+ 17 Dec 2012; Markos Chandras <hwoarang@gentoo.org>
+ +arno-iptables-firewall-2.0.1d.ebuild, +files/rc.firewall_replace_opts.patch,
+ metadata.xml:
+ Version bump. Fixes 447386. Also fixes outstanding #309473 and #411661. Thanks
+ to Ferenc Erki <erkiferenc@gmail.com>
*arno-iptables-firewall-1.9.2d (10 Oct 2009)
@@ -29,4 +37,3 @@
Initial import. Ebuild loosely based on previous ebuilds from Christian
Loitsch <gentoo-bug@loitsch.org> and Avuton Olrich <avuton@gmail.com>.
Closing bug #20726.
-
diff --git a/net-firewall/arno-iptables-firewall/arno-iptables-firewall-2.0.1d.ebuild b/net-firewall/arno-iptables-firewall/arno-iptables-firewall-2.0.1d.ebuild
new file mode 100644
index 000000000000..f4fa66ee7ef4
--- /dev/null
+++ b/net-firewall/arno-iptables-firewall/arno-iptables-firewall-2.0.1d.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/arno-iptables-firewall/arno-iptables-firewall-2.0.1d.ebuild,v 1.1 2012/12/17 19:45:41 hwoarang Exp $
+
+EAPI=4
+
+DESCRIPTION="Arno's iptables firewall script"
+HOMEPAGE="http://rocky.eld.leidenuniv.nl"
+SRC_URI="http://rocky.eld.leidenuniv.nl/${PN}/${PN}_${PV}.tar.gz"
+
+S=${WORKDIR}/${PN}_${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+plugins"
+
+DEPEND=">=net-firewall/iptables-1.2.5
+ >=sys-apps/iproute2-2.6.35-r2"
+RDEPEND="${DEPEND}"
+
+inherit linux-info
+
+pkg_pretend() {
+ if use kernel_linux; then
+ if [[ -e "${EROOT}usr/src/linux/.config" ]]; then
+ CONFIG_CHECK="IP_NF_IPTABLES"
+ check_extra_config
+ fi
+fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/rc.firewall_replace_opts.patch"
+}
+
+src_install() {
+
+ insinto /etc/arno-iptables-firewall
+
+ sed -e 's:/usr/local/share/:/usr/share/:' \
+ etc/arno-iptables-firewall/firewall.conf > \
+ "${T}"/firewall.conf || die
+ doins "${T}"/firewall.conf
+ doins etc/arno-iptables-firewall/custom-rules
+
+ sed -e 's:local/::' \
+ contrib/Gentoo/firewall.conf > \
+ "${T}"/arno-iptables-firewall.confd || die
+ newconfd "${T}"/arno-iptables-firewall.confd arno-iptables-firewall
+ newinitd contrib/Gentoo/rc.firewall arno-iptables-firewall
+
+ dobin bin/arno-fwfilter
+ dosbin bin/arno-iptables-firewall
+
+ insinto /usr/share/arno-iptables-firewall/
+ doins share/arno-iptables-firewall/environment
+
+ if use plugins
+ then
+ insinto /etc/arno-iptables-firewall/plugins
+ doins etc/arno-iptables-firewall/plugins/*
+
+ insinto /usr/share/arno-iptables-firewall/plugins
+ doins share/arno-iptables-firewall/plugins/*.plugin
+
+ exeinto /usr/share/arno-iptables-firewall/plugins
+ doexe share/arno-iptables-firewall/plugins/dyndns-host-open-helper
+
+ doexe share/arno-iptables-firewall/plugins/traffic-accounting-helper
+ doexe share/arno-iptables-firewall/plugins/traffic-accounting-log-rotate
+
+ doexe share/arno-iptables-firewall/plugins/traffic-accounting-show
+
+ docinto plugins
+ dodoc share/arno-iptables-firewall/plugins/*.CHANGELOG
+ fi
+
+ dodoc CHANGELOG README
+
+ doman share/man/man1/arno-fwfilter.1 \
+ share/man/man8/arno-iptables-firewall.8
+
+}
+
+pkg_postinst () {
+ elog "You will need to configure /etc/${PN}/firewall.conf before using this"
+ elog "package. To start the script, run:"
+ elog " /etc/init.d/${PN} start"
+ echo
+ elog "If you want to start this script at boot, run:"
+ elog " rc-update add ${PN} default"
+ echo
+ ewarn "When you start the firewall, the default is to"
+ ewarn "DROP ALL existing connections! So be careful when installing"
+ ewarn "on a remote host! There is an option to disable this behaviour"
+ ewarn "for testing."
+ echo
+ ewarn "When you stop this script, all firewall rules are flushed!"
+ echo
+}
diff --git a/net-firewall/arno-iptables-firewall/files/rc.firewall_replace_opts.patch b/net-firewall/arno-iptables-firewall/files/rc.firewall_replace_opts.patch
new file mode 100644
index 000000000000..6c271d5584b3
--- /dev/null
+++ b/net-firewall/arno-iptables-firewall/files/rc.firewall_replace_opts.patch
@@ -0,0 +1,11 @@
+--- contrib/Gentoo/rc.firewall 2012-11-29 08:44:13.000000000 +0100
++++ contrib/Gentoo/rc.firewall.new 2012-12-15 18:38:12.179072084 +0100
+@@ -1,6 +1,7 @@
+ #!/sbin/runscript
+
+-opts="${opts} stats help reload"
++extra_commands="stats help"
++extra_started_commands="reload"
+
+ depend() {
+ before net
diff --git a/net-firewall/arno-iptables-firewall/metadata.xml b/net-firewall/arno-iptables-firewall/metadata.xml
index c3f7f01b3e46..5a526d1b97d2 100644
--- a/net-firewall/arno-iptables-firewall/metadata.xml
+++ b/net-firewall/arno-iptables-firewall/metadata.xml
@@ -1,8 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+<herd>proxy-maintainers</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>erkiferenc@gmail.com</email>
+ <name>Ferenc Erki</name>
</maintainer>
<use>
<flag name='plugins'>Install optional plugins</flag>