summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-26 08:31:50 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-26 08:31:50 +0000
commit002326ea971fc74b5ef5b12215f90ac27f606507 (patch)
tree3496f56b13eb9c332db9d3613ae2941bb19768ba /net-firewall/ipp2p
parentstable on ppc gsla: 68571 (diff)
downloadgentoo-2-002326ea971fc74b5ef5b12215f90ac27f606507.tar.gz
gentoo-2-002326ea971fc74b5ef5b12215f90ac27f606507.tar.bz2
gentoo-2-002326ea971fc74b5ef5b12215f90ac27f606507.zip
Initial ebuild provided by me. This is a netfilter module to deal with p2p applications.
Diffstat (limited to 'net-firewall/ipp2p')
-rw-r--r--net-firewall/ipp2p/ChangeLog10
-rw-r--r--net-firewall/ipp2p/Manifest2
-rw-r--r--net-firewall/ipp2p/files/digest-ipp2p-0.61
-rw-r--r--net-firewall/ipp2p/files/ipp2p-0.6-Makefile.patch34
-rw-r--r--net-firewall/ipp2p/ipp2p-0.6.ebuild49
-rw-r--r--net-firewall/ipp2p/metadata.xml8
6 files changed, 104 insertions, 0 deletions
diff --git a/net-firewall/ipp2p/ChangeLog b/net-firewall/ipp2p/ChangeLog
new file mode 100644
index 000000000000..97a031cb792c
--- /dev/null
+++ b/net-firewall/ipp2p/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-firewall/ipp2p
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.1 2004/10/26 08:31:50 eradicator Exp $
+
+*ipp2p-0.6 (26 Oct 2004)
+
+ 26 Oct 2004; Jeremy Huddleston <eradicator@gentoo.org> +metadata.xml,
+ +files/ipp2p-0.6-Makefile.patch, +ipp2p-0.6.ebuild:
+ Ebuild provided by me.
+
diff --git a/net-firewall/ipp2p/Manifest b/net-firewall/ipp2p/Manifest
new file mode 100644
index 000000000000..947cd9b548dc
--- /dev/null
+++ b/net-firewall/ipp2p/Manifest
@@ -0,0 +1,2 @@
+MD5 5cb4ef39f1b7de7dc367c2788960461a ipp2p-0.6.ebuild 3111
+MD5 7dde11c31f867f3b9c624ac8dcb944a4 files/digest-ipp2p-0.6 58
diff --git a/net-firewall/ipp2p/files/digest-ipp2p-0.6 b/net-firewall/ipp2p/files/digest-ipp2p-0.6
new file mode 100644
index 000000000000..bf369b132197
--- /dev/null
+++ b/net-firewall/ipp2p/files/digest-ipp2p-0.6
@@ -0,0 +1 @@
+MD5 9ac3ab4f48755500dbb0020292088efe ipp2p.06.tar.gz 6752
diff --git a/net-firewall/ipp2p/files/ipp2p-0.6-Makefile.patch b/net-firewall/ipp2p/files/ipp2p-0.6-Makefile.patch
new file mode 100644
index 000000000000..3acd9b687591
--- /dev/null
+++ b/net-firewall/ipp2p/files/ipp2p-0.6-Makefile.patch
@@ -0,0 +1,34 @@
+--- Makefile.orig 2004-10-26 01:21:56.916739945 -0700
++++ Makefile 2004-10-26 01:22:16.672041397 -0700
+@@ -20,16 +20,12 @@
+ SED = sed
+ IPTABLES = /sbin/iptables
+ IPTABLES_VERSION = \
+- $(shell iptables --version | sed -e 's/^iptables v//')
++ $(shell $(IPTABLES) --version | sed -e 's/^iptables v//')
+ IPTABLES_OPTION = -DNETFILTER_VERSION=\"$(IPTABLES_VERSION)\"
+
+
+ KERNEL_SRC = /lib/modules/$(shell uname -r)/build
+-IUSER = -I/usr/src/iptables-1.2.9/include
+ CC = gcc
+-CFLAGS = -O2 -Wall
+-
+-
+
+ all: modules libipt_ipp2p.so
+
+@@ -39,11 +35,10 @@
+ $(CC) $(CFLAGS) -I$(KERNEL_SRC)/include -c ipt_ipp2p.c -D__KERNEL__ -DMODULE $(MODVERSIONS)
+
+ ipt_ipp2p.ko:
+- $(MAKE) -C $(KERNEL_SRC) SUBDIRS=$(PWD) modules
+-
++ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules
+
+ libipt_ipp2p.so: libipt_ipp2p.c ipt_ipp2p.h
+- $(CC) $(CFLAGS) $(IPTABLES_OPTION) $(IUSER) -fPIC -c libipt_ipp2p.c
++ $(CC) $(CFLAGS) $(IPTABLES_OPTION) -fPIC -c libipt_ipp2p.c
+ ld -shared -o libipt_ipp2p.so libipt_ipp2p.o
+
+ clean:
diff --git a/net-firewall/ipp2p/ipp2p-0.6.ebuild b/net-firewall/ipp2p/ipp2p-0.6.ebuild
new file mode 100644
index 000000000000..8f5ad0dd195a
--- /dev/null
+++ b/net-firewall/ipp2p/ipp2p-0.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ipp2p-0.6.ebuild,v 1.1 2004/10/26 08:31:50 eradicator Exp $
+
+IUSE=""
+
+inherit kernel-mod eutils
+
+MY_PV=${PV/./}
+MY_P="${PN}.${MY_PV}"
+S="${WORKDIR}/${PN}"
+
+DESCRIPTION="Netfilter module for dealing with P2P Applications."
+HOMEPAGE="http://rnvs.informatik.uni-leipzig.de/ipp2p/index_en.html"
+SRC_URI="http://rnvs.informatik.uni-leipzig.de/ipp2p/downloads/${MY_P}.tar.gz"
+
+SLOT="${KV}"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/modutils"
+
+DEPEND="${RDEPEND}
+ >=net-firewall/iptables-1.2.11
+ virtual/linux-sources"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-Makefile.patch
+}
+
+src_compile() {
+ unset ARCH
+ emake KERNEL_SRC=${KERNEL_DIR} || die "Parallel Make Failed"
+}
+
+
+src_install() {
+ exeinto /$(get_libdir)/iptables
+ doexe libipt_ipp2p.so
+
+ kernel-mod_getversion
+ insinto /lib/modules/${KV_MK_VERSION_FULL}/kernel/net/ipv4/netfilter
+ doins ipt_ipp2p.ko
+
+ dodoc README
+}
diff --git a/net-firewall/ipp2p/metadata.xml b/net-firewall/ipp2p/metadata.xml
new file mode 100644
index 000000000000..15a401e91b43
--- /dev/null
+++ b/net-firewall/ipp2p/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>eradicator@gentoo.org</email>
+</maintainer>
+</pkgmetadata>