summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-05-20 09:05:50 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-05-20 09:05:50 +0000
commit510293b9bf74a284409aa67ffec2d719a22d5811 (patch)
tree4ca0161df79ca5aee10fdb14f0428d6584a5ffcf /net-firewall/ufw/ufw-0.34_pre805.ebuild
parentadd systemd support to both 2.2 and 2.4 branches on behalf of the systemd tea... (diff)
downloadgentoo-2-510293b9bf74a284409aa67ffec2d719a22d5811.tar.gz
gentoo-2-510293b9bf74a284409aa67ffec2d719a22d5811.tar.bz2
gentoo-2-510293b9bf74a284409aa67ffec2d719a22d5811.zip
add systemd unit on behalf of the systemd team, fix bug #466562
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key ADC916E5)
Diffstat (limited to 'net-firewall/ufw/ufw-0.34_pre805.ebuild')
-rw-r--r--net-firewall/ufw/ufw-0.34_pre805.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-firewall/ufw/ufw-0.34_pre805.ebuild b/net-firewall/ufw/ufw-0.34_pre805.ebuild
index d60d6b67af3b..8b714b5b31dd 100644
--- a/net-firewall/ufw/ufw-0.34_pre805.ebuild
+++ b/net-firewall/ufw/ufw-0.34_pre805.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ufw-0.34_pre805.ebuild,v 1.1 2012/12/17 19:20:54 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ufw-0.34_pre805.ebuild,v 1.2 2013/05/20 09:05:50 lxnay Exp $
EAPI=4
PYTHON_DEPEND="2:2.6 3:3.1"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.5 *-jython"
-inherit bash-completion-r1 eutils linux-info distutils
+inherit bash-completion-r1 eutils linux-info distutils systemd
DESCRIPTION="A program used to manage a netfilter firewall"
HOMEPAGE="http://launchpad.net/ufw"
@@ -133,6 +133,7 @@ src_prepare() {
src_install() {
newconfd "${FILESDIR}"/ufw.confd ufw
newinitd "${FILESDIR}"/ufw-2.initd ufw
+ systemd_dounit "${FILESDIR}/ufw.service"
exeinto /usr/share/${PN}
doexe tests/check-requirements