summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2004-10-23 18:18:47 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2004-10-23 18:18:47 +0000
commit6315710ff044584b8f1fec56f82fa50ac997e39a (patch)
tree5cc19ed19e3e9d67808bc2449c864ca56a242633 /net-fs/coda
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-6315710ff044584b8f1fec56f82fa50ac997e39a.tar.gz
gentoo-2-6315710ff044584b8f1fec56f82fa50ac997e39a.tar.bz2
gentoo-2-6315710ff044584b8f1fec56f82fa50ac997e39a.zip
Improved venus init script as well as coda's pkg_config
Diffstat (limited to 'net-fs/coda')
-rw-r--r--net-fs/coda/ChangeLog7
-rw-r--r--net-fs/coda/coda-6.0.7.ebuild23
-rw-r--r--net-fs/coda/files/6.0.7/venus31
3 files changed, 54 insertions, 7 deletions
diff --git a/net-fs/coda/ChangeLog b/net-fs/coda/ChangeLog
index 6ee0c175d122..7e2749d414f9 100644
--- a/net-fs/coda/ChangeLog
+++ b/net-fs/coda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/coda
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/ChangeLog,v 1.12 2004/10/23 15:33:57 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/ChangeLog,v 1.13 2004/10/23 18:18:47 griffon26 Exp $
+
+ 23 Oct 2004; Maurice van der Pot <griffon26@gentoo.org> +files/6.0.7/venus,
+ coda-6.0.7.ebuild:
+ Fixed init script to not start venus in the background as it now daemonizes
+ after startup. Also adapted pkg_config to work with new createvol_rep.
*coda-6.0.7 (23 Oct 2004)
diff --git a/net-fs/coda/coda-6.0.7.ebuild b/net-fs/coda/coda-6.0.7.ebuild
index 902f4f3e4f5f..3c051294875c 100644
--- a/net-fs/coda/coda-6.0.7.ebuild
+++ b/net-fs/coda/coda-6.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.7.ebuild,v 1.1 2004/10/23 15:33:57 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.7.ebuild,v 1.2 2004/10/23 18:18:47 griffon26 Exp $
inherit eutils
@@ -77,7 +77,7 @@ src_install () {
dodoc README* ChangeLog CREDITS LICENSE
exeinto /etc/init.d
- doexe ${FILESDIR}/venus
+ doexe ${FILESDIR}/${PV}/venus
doexe ${FILESDIR}/coda-update
doexe ${FILESDIR}/codasrv
doexe ${FILESDIR}/auth2
@@ -230,15 +230,26 @@ pkg_config () {
einfo "Creating root volume..."
# Create root volume
- createvol_rep ${CODA_ROOT_VOLUME} E0000100 ${CODA_STORAGE_DIR}/${VICE_PARTITION} &> /dev/null <<- EOF
+ createvoloutput=`createvol_rep ${CODA_ROOT_VOLUME} ${FQDN} 2>&1 <<- EOF
n
- EOF
+ EOF`
+ if ! volutil info ${CODA_ROOT_VOLUME} &> /dev/null
+ then
+ eerror "Unable to create root volume, output of createvol_rep follows"
+ echo "$createvoloutput"
+ exit 1
+ fi
einfo "Creating writable volume..."
# Create test volume
- createvol_rep ${CODA_TEST_VOLUME} E0000100 ${CODA_STORAGE_DIR}/${VICE_PARTITION} &> /dev/null <<- EOF
+ createvoloutput=`createvol_rep ${CODA_TEST_VOLUME} ${FQDN} 2>&1 <<- EOF
n
- EOF
+ EOF`
+ if ! volutil info ${CODA_TEST_VOLUME} &> /dev/null; then
+ eerror "Unable to create writable volume, output of createvol_rep follows"
+ echo "$createvoloutput"
+ exit 1
+ fi
einfo "Setting up venus (the coda client)..."
venus-setup ${FQDN} 20000 > /dev/null
diff --git a/net-fs/coda/files/6.0.7/venus b/net-fs/coda/files/6.0.7/venus
new file mode 100644
index 000000000000..d8a262c0cead
--- /dev/null
+++ b/net-fs/coda/files/6.0.7/venus
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/6.0.7/venus,v 1.1 2004/10/23 18:18:47 griffon26 Exp $
+
+depend() {
+ need net
+ after codasrv
+}
+
+checkconfig() {
+ if ! /usr/sbin/codaconfedit venus.conf &>/dev/null; then
+ eerror "Please run venus-setup before starting the service..."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting venus"
+ start-stop-daemon --start --quiet --exec /usr/sbin/venus > /dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping venus"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/venus
+ umount -l coda &>/dev/null
+ eend $?
+}