summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-14 02:34:05 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-14 02:34:05 +0000
commit7d7c3a737692b185d488962160a68d20e2214aa4 (patch)
tree1391f0e7556be79fbdf0685c962de7ca56e0b909 /net-fs/nfs-utils/nfs-utils-1.0.6-r4.ebuild
parenthppa KEYWORDS #70866 (Manifest recommit) (diff)
downloadgentoo-2-7d7c3a737692b185d488962160a68d20e2214aa4.tar.gz
gentoo-2-7d7c3a737692b185d488962160a68d20e2214aa4.tar.bz2
gentoo-2-7d7c3a737692b185d488962160a68d20e2214aa4.zip
prune old
Diffstat (limited to 'net-fs/nfs-utils/nfs-utils-1.0.6-r4.ebuild')
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.6-r4.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.6-r4.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.6-r4.ebuild
index 3872a6202f2d..f1586be91c04 100644
--- a/net-fs/nfs-utils/nfs-utils-1.0.6-r4.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-1.0.6-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.6-r4.ebuild,v 1.8 2004/11/09 19:53:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.6-r4.ebuild,v 1.9 2004/11/14 02:34:05 vapier Exp $
inherit gnuconfig
@@ -13,13 +13,13 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
IUSE="tcpd"
-DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
-RDEPEND="${DEPEND}
+RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
>=net-nds/portmap-5b-r6
>=sys-apps/util-linux-2.11f"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51"
src_compile() {
- gnuconfig_update
econf \
--mandir=/usr/share/man \
--with-statedir=/var/lib/nfs \
@@ -33,12 +33,15 @@ src_compile() {
fi
# parallel make fails for depend target
- make depend || die "failed to make depend"
+ emake -j1 depend || die "failed to make depend"
emake || die "Failed to compile"
}
src_install() {
- make install install_prefix=${D} MANDIR=${D}/usr/share/man \
+ make \
+ install_prefix=${D} \
+ MANDIR=${D}/usr/share/man \
+ install \
|| die "Failed to install"
# Don't overwrite existing xtab/etab, install the original
@@ -51,19 +54,15 @@ src_install() {
# Install some client-side binaries in /sbin
dodir /sbin
- mv ${D}/usr/sbin/rpc.{lockd,statd} ${D}/sbin
+ mv ${D}/usr/sbin/rpc.{lockd,statd} ${D}/sbin/
dodoc ChangeLog README
docinto linux-nfs ; dodoc linux-nfs/*
insinto /etc ; doins ${FILESDIR}/exports
- exeinto /etc/init.d
- newexe ${FILESDIR}/nfs-5 nfs
- newexe ${FILESDIR}/nfsmount nfsmount
-
- insinto /etc/conf.d
- newins ${FILESDIR}/nfs.confd nfs
+ doinitd ${FILESDIR}/nfs ${FILESDIR}/nfsmount
+ newconfd ${FILESDIR}/nfs.confd nfs
}
pkg_postinst() {