summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-24 00:25:09 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-24 00:25:09 +0000
commit208722e5beca6556e00fc81ed8eeafe1d3894403 (patch)
treebb9b9c74b18077718f540dc0844684d16da30cad /net-fs/nfs-utils
parentcp -a -> cp -pPR #103487 (diff)
downloadgentoo-2-208722e5beca6556e00fc81ed8eeafe1d3894403.tar.gz
gentoo-2-208722e5beca6556e00fc81ed8eeafe1d3894403.tar.bz2
gentoo-2-208722e5beca6556e00fc81ed8eeafe1d3894403.zip
cp -a -> cp -pPR #103487 and install rpcgen for uClibc targets
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-fs/nfs-utils')
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.7-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.7-r1.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.7-r1.ebuild
index eeb7726d0e89..1bb4c9ebb680 100644
--- a/net-fs/nfs-utils/nfs-utils-1.0.7-r1.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-1.0.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.7-r1.ebuild,v 1.5 2005/06/02 00:40:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.7-r1.ebuild,v 1.6 2005/08/24 00:25:09 vapier Exp $
inherit gnuconfig eutils flag-o-matic
@@ -87,6 +87,12 @@ src_install() {
doinitd "${FILESDIR}"/nfs "${FILESDIR}"/nfsmount
newconfd "${FILESDIR}"/nfs.confd nfs
+
+ # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
+ if ! use elibc_glibc ; then
+ dobin tools/rpcgen/rpcgen || die "rpcgen"
+ newdoc tools/rpcgen/README README.rpcgen
+ fi
}
pkg_preinst() {
@@ -104,6 +110,6 @@ pkg_postinst() {
for f in "${ROOT}"/usr/lib/nfs/*; do
[[ -f ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
einfo "Copying default ${f##*/} from /usr/lib/nfs to /var/lib/nfs"
- cp -a ${f} "${ROOT}"/var/lib/nfs/
+ cp -pPR ${f} "${ROOT}"/var/lib/nfs/
done
}