summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-07-08 10:54:00 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-07-08 10:54:00 +0000
commit441a628dfb0759aae785fded57d61dd77f8780ba (patch)
tree67aadf626c2bad3efdaa445b2031fd73360480e5 /net-fs
parentAdd pypy support, IUSE examples (diff)
downloadgentoo-2-441a628dfb0759aae785fded57d61dd77f8780ba.tar.gz
gentoo-2-441a628dfb0759aae785fded57d61dd77f8780ba.tar.bz2
gentoo-2-441a628dfb0759aae785fded57d61dd77f8780ba.zip
Version bump. Removed old
(Portage version: 2.2.0_alpha187/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog8
-rw-r--r--net-fs/samba/samba-4.0.7.ebuild (renamed from net-fs/samba/samba-4.0.5.ebuild)24
2 files changed, 17 insertions, 15 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 59fb10e46236..3ad4f646b53f 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.582 2013/06/20 18:23:54 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.583 2013/07/08 10:54:00 polynomial-c Exp $
+
+*samba-4.0.7 (08 Jul 2013)
+
+ 08 Jul 2013; Lars Wendler <polynomial-c@gentoo.org> -samba-4.0.5.ebuild,
+ +samba-4.0.7.ebuild:
+ Version bump. Removed old.
20 Jun 2013; Lars Wendler <polynomial-c@gentoo.org> samba-3.6.16.ebuild:
Added sys-libs/tevent to DEPEND. Thanks to Grzegorz {NineX} Krzystek for
diff --git a/net-fs/samba/samba-4.0.5.ebuild b/net-fs/samba/samba-4.0.7.ebuild
index 059006ab6568..47289f2cbfbc 100644
--- a/net-fs/samba/samba-4.0.5.ebuild
+++ b/net-fs/samba/samba-4.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.0.5.ebuild,v 1.3 2013/05/08 06:00:01 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.0.7.ebuild,v 1.1 2013/07/08 10:54:00 polynomial-c Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
@@ -35,7 +35,7 @@ RDEPEND="${PYTHON_DEPS}
virtual/libiconv
dev-python/subunit
sys-libs/libcap
- >=sys-libs/ldb-1.1.15
+ >=sys-libs/ldb-1.1.16
>=sys-libs/tdb-1.2.11[python]
>=sys-libs/talloc-2.0.8[python]
>=sys-libs/tevent-0.9.18
@@ -60,8 +60,6 @@ CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
WAF_BINARY="${S}/buildtools/bin/waf"
-PATCHES=( "${FILESDIR}/${P}-fix_linking_to_heimdal.patch" )
-
pkg_setup() {
python_export_best
if use aio; then
@@ -118,20 +116,18 @@ src_configure() {
src_install() {
waf-utils_src_install
- python_replicate_script \
- "${D}/usr/sbin/samba_dnsupdate" \
- "${D}/usr/sbin/samba_spnupdate" \
- "${D}/usr/sbin/samba_upgradedns" \
- "${D}/usr/sbin/samba_kcc" \
- "${D}/usr/bin/samba-tool"
+ # Seems like the build script gets the shebangs correct by itself
+ # (4.0.6)
+ #python_replicate_script \
+ # "${D}/usr/sbin/samba_dnsupdate" \
+ # "${D}/usr/sbin/samba_spnupdate" \
+ # "${D}/usr/sbin/samba_upgradedns" \
+ # "${D}/usr/sbin/samba_kcc" \
+ # "${D}/usr/bin/samba-tool"
# Make all .so files executable
find "${D}" -type f -name "*.so" -exec chmod +x {} +
- # Move all LDB modules to their correct path
- mkdir -p "${D}"/usr/$(get_libdir)/ldb/modules/ldb
- mv "${D}"/usr/$(get_libdir)/ldb/*.so "${D}"/usr/$(get_libdir)/ldb/modules/ldb
-
# Install init script and conf.d file
newinitd "${CONFDIR}/samba4.initd-r1" samba
newconfd "${CONFDIR}/samba4.confd" samba