summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2011-05-09 18:12:23 +0000
committerVictor Ostorga <vostorga@gentoo.org>2011-05-09 18:12:23 +0000
commit8b5073b110394f57f16923d7ab5aac44eadc340e (patch)
treece28dce815a509c41da0732b6255d086f8defc20 /net-fs
parentx86 stable per bug 362871 (diff)
downloadgentoo-2-8b5073b110394f57f16923d7ab5aac44eadc340e.tar.gz
gentoo-2-8b5073b110394f57f16923d7ab5aac44eadc340e.tar.bz2
gentoo-2-8b5073b110394f57f16923d7ab5aac44eadc340e.zip
Shining up checking of CIFS kernel parameter, thanks to Jeremy Olexa <darkside@gentoo.org> bug #364679
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/cifs-utils/ChangeLog7
-rw-r--r--net-fs/cifs-utils/cifs-utils-4.8.1.ebuild22
2 files changed, 11 insertions, 18 deletions
diff --git a/net-fs/cifs-utils/ChangeLog b/net-fs/cifs-utils/ChangeLog
index 9785d6145ec3..2d958453ede1 100644
--- a/net-fs/cifs-utils/ChangeLog
+++ b/net-fs/cifs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/cifs-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.6 2011/04/27 17:59:15 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.7 2011/05/09 18:12:23 vostorga Exp $
+
+ 09 May 2011; Víctor Ostorga <vostorga@gentoo.org>
+ cifs-utils-4.8.1.ebuild:
+ Shining up checking of CIFS kernel parameter, thanks to Jeremy Olexa
+ <darkside@gentoo.org> bug #364679
27 Apr 2011; Víctor Ostorga <vostorga@gentoo.org>
cifs-utils-4.8.1.ebuild:
diff --git a/net-fs/cifs-utils/cifs-utils-4.8.1.ebuild b/net-fs/cifs-utils/cifs-utils-4.8.1.ebuild
index e51134d3708c..d718b88cf8cf 100644
--- a/net-fs/cifs-utils/cifs-utils-4.8.1.ebuild
+++ b/net-fs/cifs-utils/cifs-utils-4.8.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/cifs-utils-4.8.1.ebuild,v 1.7 2011/04/27 17:59:15 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/cifs-utils-4.8.1.ebuild,v 1.8 2011/05/09 18:12:23 vostorga Exp $
EAPI=2
-inherit eutils confutils linux-mod
+inherit eutils confutils linux-info
DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
HOMEPAGE="http://www.samba.org/linux-cifs/cifs-utils/"
@@ -23,12 +23,9 @@ DEPEND="!net-fs/mount-cifs
creds? ( sys-apps/keyutils )"
RDEPEND="${DEPEND}"
-cifs_check() {
- ebegin "Checking for CIFS support"
- linux_chkconfig_present CIFS
- eend $?
-
- if [[ $? -ne 0 ]] ; then
+pkg_setup() {
+ confutils_use_conflict caps caps-ng
+ if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
ewarn "You must enable CIFS support in your kernel config, "
ewarn "to be able to mount samba shares. You can find it at"
ewarn
@@ -40,15 +37,6 @@ cifs_check() {
fi
}
-pkg_setup() {
- confutils_use_conflict caps caps-ng
-
- if use kernel_linux; then
- linux-mod_pkg_setup
- cifs_check
- fi
-}
-
src_configure() {
econf \
$(use_enable ads cifsupcall) \