summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-07-01 15:36:34 +0000
committerAchim Gottinger <achim@gentoo.org>2001-07-01 15:36:34 +0000
commit97a9cfa2263d2be3a33a4acaca02706896300134 (patch)
treef43f465a90ccb98f8903fa75842e1cf3d69aa7a6 /net-fs
parent*** empty log message *** (diff)
downloadgentoo-2-97a9cfa2263d2be3a33a4acaca02706896300134.tar.gz
gentoo-2-97a9cfa2263d2be3a33a4acaca02706896300134.tar.bz2
gentoo-2-97a9cfa2263d2be3a33a4acaca02706896300134.zip
Added pam to dependencies, fixed SRC_URI in 1.0.4-r1 and added a separate package
for 1.0.4a
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/openafs/files/digest-openafs-1.0.4a1
-rw-r--r--net-fs/openafs/openafs-1.0.4-r1.ebuild5
-rw-r--r--net-fs/openafs/openafs-1.0.4a.ebuild101
3 files changed, 105 insertions, 2 deletions
diff --git a/net-fs/openafs/files/digest-openafs-1.0.4a b/net-fs/openafs/files/digest-openafs-1.0.4a
new file mode 100644
index 000000000000..fb64fb4eced1
--- /dev/null
+++ b/net-fs/openafs/files/digest-openafs-1.0.4a
@@ -0,0 +1 @@
+MD5 72c583e09a317bfa34d637e8f108a1dd openafs-1.0.4a-src.tar.bz2
diff --git a/net-fs/openafs/openafs-1.0.4-r1.ebuild b/net-fs/openafs/openafs-1.0.4-r1.ebuild
index 75f64e6d5644..0424ac2dc609 100644
--- a/net-fs/openafs/openafs-1.0.4-r1.ebuild
+++ b/net-fs/openafs/openafs-1.0.4-r1.ebuild
@@ -11,11 +11,12 @@ an architecture geared towards system management, along with the tools
to perform important management tasks. For a user, AFS is a familiar yet
extensive UNIX environment for accessing files easily and quickly."
-SRC_URI="http://www.openafs.org/dl/openafs/1.0.4a/openafs-1.0.4a-src.tar.bz2"
+SRC_URI="http://www.openafs.org/dl/openafs/1.0.4/openafs-1.0.4-src.tar.bz2"
HOMEPAGE="http://www.openafs.org/"
DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2"
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/pam-0.75"
src_compile() {
diff --git a/net-fs/openafs/openafs-1.0.4a.ebuild b/net-fs/openafs/openafs-1.0.4a.ebuild
new file mode 100644
index 000000000000..8b423aa495a2
--- /dev/null
+++ b/net-fs/openafs/openafs-1.0.4a.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Holger Brueckner <darks@fet.org>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The AFS 3 distributed file system targets the issues critical to
+distributed computing environments. AFS performs exceptionally well,
+both within small, local work groups of machines and across wide-area
+configurations in support of large, collaborative efforts. AFS provides
+an architecture geared towards system management, along with the tools
+to perform important management tasks. For a user, AFS is a familiar yet
+extensive UNIX environment for accessing files easily and quickly."
+
+SRC_URI="http://www.openafs.org/dl/openafs/1.0.4a/openafs-1.0.4a-src.tar.bz2"
+HOMEPAGE="http://www.openafs.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/pam-0.75"
+
+
+src_compile() {
+
+ export KERNELVERSION=`grep "UTS_RELEASE" /usr/src/linux/include/linux/version.h | awk '{print $3}' | sed "s/\"//g"`
+ KERNELSHORT=`echo $KERNELVERSION | cut -c1-3 | sed "s/\.//"`
+ SYSTEM="linux"
+ SYSARCH="i386"
+ CELLNAME=`cat ${FILESDIR}/ThisCell`
+
+ try mkdir ${SYSARCH}_${SYSTEM}${KERNELSHORT}
+ try mkdir ${SYSARCH}_${SYSTEM}${KERNELSHORT}/dest
+ try mkdir ${SYSARCH}_${SYSTEM}${KERNELSHORT}/obj
+ ln -s "@sys/dest" dest
+ ln -s "@sys/obj" obj
+ ln -s ${SYSARCH}_${SYSTEM}${KERNELSHORT} @sys
+ ln -s src/Makefile Makefile
+ try make links
+ try make SYS_NAME="${SYSARCH}_${SYSTEM}${KERNELSHORT}" \
+ LINUX_VERS="${KERNELVERSION}" TXLIBS=/lib/libncurses.so \
+ OPTMZ=\"$CFLAGS\" XCFLAGS=\"$CFLAGS\" \
+ PAM_CFLAGS=\"$CFLAGS -Dlinux -DLINUX_PAM -fPIC\"
+}
+
+src_install () {
+
+
+ # Client
+
+ cd ${S}/dest/root.client/usr/vice
+
+ insinto /etc/afs/modload
+ doins etc/modload/*
+ insinto /etc/afs/C
+ doins etc/C/*
+
+ insinto /etc/afs
+ doins ${FILESDIR}/{ThisCell,CellServDB}
+ doins etc/afs.conf
+
+ dodir /afs
+
+ exeinto /etc/rc.d/init.d
+ newexe ${FILESDIR}/afs.rc afs
+
+ dosbin etc/afsd
+
+ # Client Bin
+ cd ${S}/dest
+ exeinto /usr/afsws/bin
+ doexe bin/*
+
+ exeinto /etc/afs/afsws
+ doexe etc/*
+
+ cp -a include lib ${D}/usr/afsws
+ dosym /usr/afsws/lib/afs/libtermlib.a /usr/afsws/lib/afs/libnull.a
+
+ # Server
+ cd ${S}/dest/root.server/usr/afs
+ exeinto /usr/afs/bin
+ doexe bin/*
+
+ dodir /usr/vice
+ dosym /etc/afs /usr/vice/etc
+ dosym /etc/afs/afsws /usr/afsws/etc
+
+ dodoc ${FILESDIR}/README
+}
+
+pkg_postinst () {
+ if [ "$PN" = "openafs_client" ]
+ then
+ echo ">>> UPDATE CellServDB and ThisCell to your needs !!"
+ elif [ "$PN" = "openafs_client_bin" ]
+ then
+ echo ">>> UPDATE CellServDB and ThisCell to your needs !!"
+ else
+ echo ">>> FOLLOW THE INSTRUCTIONS IN AFS QUICK BEGINNINGS"
+ echo ">>> PAGE >45 TO DO INITIAL SERVER SETUP"
+ fi
+}