summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-04-06 15:03:01 +0000
committerPeter Volkov <pva@gentoo.org>2011-04-06 15:03:01 +0000
commite0b7857437c0db1c1bf7fbe1ccaa43d3f4438c4e (patch)
treeb067951e4172a553e207bd288cc4394674f69833 /net-fs
parentUpdate all manifests cause they are all borked (this time it is unsigned, dun... (diff)
downloadgentoo-2-e0b7857437c0db1c1bf7fbe1ccaa43d3f4438c4e.tar.gz
gentoo-2-e0b7857437c0db1c1bf7fbe1ccaa43d3f4438c4e.tar.bz2
gentoo-2-e0b7857437c0db1c1bf7fbe1ccaa43d3f4438c4e.zip
Fix build issue with USE='ldap -sasl', bug #361899, thank Justin Lecher for report and Dustin Polke for this fix.
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/ChangeLog8
-rw-r--r--net-fs/autofs/autofs-5.0.5-r2.ebuild5
-rw-r--r--net-fs/autofs/files/autofs-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch28
3 files changed, 39 insertions, 2 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index 00603ceec3b0..a1b4afbb34eb 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/autofs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.102 2011/04/06 14:10:32 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.103 2011/04/06 15:03:01 pva Exp $
+
+ 06 Apr 2011; Peter Volkov <pva@gentoo.org> autofs-5.0.5-r2.ebuild,
+ +files/autofs-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patc
+ h:
+ Fix build issue with USE='ldap -sasl', bug #361899, thank Justin Lecher for
+ report and Dustin Polke for this fix.
*autofs-4.1.4 (06 Apr 2011)
diff --git a/net-fs/autofs/autofs-5.0.5-r2.ebuild b/net-fs/autofs/autofs-5.0.5-r2.ebuild
index 4c00474db3e2..96f4ce112b3a 100644
--- a/net-fs/autofs/autofs-5.0.5-r2.ebuild
+++ b/net-fs/autofs/autofs-5.0.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.5-r2.ebuild,v 1.1 2011/04/03 17:55:17 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.5-r2.ebuild,v 1.2 2011/04/06 15:03:01 pva Exp $
EAPI="4"
inherit eutils multilib autotools linux-info
@@ -57,6 +57,9 @@ src_prepare() {
# Disable LDAP specific code if USE="-ldap", let's see what upstream says...
epatch "${FILESDIR}"/${P}-fix-building-without-ldap.patch
+ # https://bugs.gentoo.org/show_bug.cgi?id=361899
+ epatch "${FILESDIR}"/${P}-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch
+
eautoreconf
}
diff --git a/net-fs/autofs/files/autofs-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch b/net-fs/autofs/files/autofs-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch
new file mode 100644
index 000000000000..4d70d2a2f766
--- /dev/null
+++ b/net-fs/autofs/files/autofs-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch
@@ -0,0 +1,28 @@
+--- ./modules/lookup_ldap.c
++++ ./modules/lookup_ldap.c
+@@ -591,10 +591,12 @@ static LDAP *do_connect(unsigned logopt, const char *uri, struct lookup_context
+ {
+ LDAP *ldap;
+
++#ifdef HAVE_SASL
+ if (ctxt->extern_cert && ctxt->extern_key) {
+ set_env(logopt, ENV_LDAPTLS_CERT, ctxt->extern_cert);
+ set_env(logopt, ENV_LDAPTLS_KEY, ctxt->extern_key);
+ }
++#endif
+
+ ldap = init_ldap_connection(logopt, uri, ctxt);
+ if (ldap) {
+@@ -1372,10 +1374,12 @@ static void free_context(struct lookup_context *ctxt)
+ defaults_free_searchdns(ctxt->sdns);
+ if (ctxt->dclist)
+ free_dclist(ctxt->dclist);
++#ifdef HAVE_SASL
+ if (ctxt->extern_cert)
+ free(ctxt->extern_cert);
+ if (ctxt->extern_key)
+ free(ctxt->extern_key);
++#endif
+ free(ctxt);
+
+ return;