summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-09 13:21:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-09 13:21:45 +0000
commit2671adecc65308232e5a6db79abfe8e4e34773d2 (patch)
treecc0d700bbad52d5311c101007b2e7612ddf7eecb /net-ftp/kftpgrabber
parentppc stable #278315 (diff)
downloadgentoo-2-2671adecc65308232e5a6db79abfe8e4e34773d2.tar.gz
gentoo-2-2671adecc65308232e5a6db79abfe8e4e34773d2.tar.bz2
gentoo-2-2671adecc65308232e5a6db79abfe8e4e34773d2.zip
Fix building with GLIBC 2.10+ wrt #273836.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/kftpgrabber')
-rw-r--r--net-ftp/kftpgrabber/ChangeLog8
-rw-r--r--net-ftp/kftpgrabber/files/kftpgrabber-0.8.1-glibc-2.10.patch26
-rw-r--r--net-ftp/kftpgrabber/kftpgrabber-0.8.1-r1.ebuild7
3 files changed, 36 insertions, 5 deletions
diff --git a/net-ftp/kftpgrabber/ChangeLog b/net-ftp/kftpgrabber/ChangeLog
index c18b241ca8f2..a675588fda47 100644
--- a/net-ftp/kftpgrabber/ChangeLog
+++ b/net-ftp/kftpgrabber/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/kftpgrabber
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/kftpgrabber/ChangeLog,v 1.27 2008/01/21 20:29:05 philantrop Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/kftpgrabber/ChangeLog,v 1.28 2009/08/09 13:21:45 ssuominen Exp $
+
+ 09 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ kftpgrabber-0.8.1-r1.ebuild, +files/kftpgrabber-0.8.1-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #273836.
21 Jan 2008; Wulf C. Krueger <philantrop@gentoo.org>
-files/kftpgrabber-0.6.0-gcc4.patch, -files/kftpgrabber-0.6.0-gcc41.patch,
diff --git a/net-ftp/kftpgrabber/files/kftpgrabber-0.8.1-glibc-2.10.patch b/net-ftp/kftpgrabber/files/kftpgrabber-0.8.1-glibc-2.10.patch
new file mode 100644
index 000000000000..c9946462d1e7
--- /dev/null
+++ b/net-ftp/kftpgrabber/files/kftpgrabber-0.8.1-glibc-2.10.patch
@@ -0,0 +1,26 @@
+diff -ur kftpgrabber-0.8.1.old/kftpgrabber/src/engine/ftpsocket.cpp kftpgrabber-0.8.1/kftpgrabber/src/engine/ftpsocket.cpp
+--- kftpgrabber-0.8.1.old/kftpgrabber/src/engine/ftpsocket.cpp 2009-08-06 04:12:45.938977940 +0300
++++ kftpgrabber-0.8.1/kftpgrabber/src/engine/ftpsocket.cpp 2009-08-06 04:13:52.117078262 +0300
+@@ -758,7 +758,7 @@
+ }
+
+ // 229 Entering Extended Passive Mode (|||55016|)
+- char *begin = strchr(socket()->getResponse().ascii(), '(');
++ const char *begin = strchr(socket()->getResponse().ascii(), '(');
+ int port;
+
+ if (!begin || sscanf(begin, "(|||%d|)", &port) != 1) {
+@@ -793,11 +793,11 @@
+
+ // Ok PASV command successfull - let's parse the result
+ int ip[6];
+- char *begin = strchr(socket()->getResponse().ascii(), '(');
++ const char *begin = strchr(socket()->getResponse().ascii(), '(');
+
+ // Some stinky servers don't respect RFC and do it on their own
+ if (!begin)
+- begin = strchr(socket()->getResponse().ascii(), '=');
++ begin = const_cast<char*> (strchr(socket()->getResponse().ascii(), '='));
+
+ if (!begin || (sscanf(begin, "(%d,%d,%d,%d,%d,%d)",&ip[0], &ip[1], &ip[2], &ip[3], &ip[4], &ip[5]) != 6 &&
+ sscanf(begin, "=%d,%d,%d,%d,%d,%d",&ip[0], &ip[1], &ip[2], &ip[3], &ip[4], &ip[5]) != 6)) {
diff --git a/net-ftp/kftpgrabber/kftpgrabber-0.8.1-r1.ebuild b/net-ftp/kftpgrabber/kftpgrabber-0.8.1-r1.ebuild
index 6a345991425c..2283e5caa683 100644
--- a/net-ftp/kftpgrabber/kftpgrabber-0.8.1-r1.ebuild
+++ b/net-ftp/kftpgrabber/kftpgrabber-0.8.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/kftpgrabber/kftpgrabber-0.8.1-r1.ebuild,v 1.7 2007/09/25 18:29:24 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/kftpgrabber/kftpgrabber-0.8.1-r1.ebuild,v 1.8 2009/08/09 13:21:45 ssuominen Exp $
inherit kde
@@ -25,7 +25,8 @@ DEPEND="${RDEPEND}
need-kde 3.5
-PATCHES="${FILESDIR}/kftpgrabber-0.8.1-inf-recursion-fix.diff"
+PATCHES=( "${FILESDIR}/kftpgrabber-0.8.1-inf-recursion-fix.diff"
+ "${FILESDIR}/${P}-glibc-2.10.patch" )
src_unpack() {
kde_src_unpack