summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-16 14:22:31 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-16 14:22:31 +0000
commitfd2f063bfa7839697ea6ff89b80c426043227d97 (patch)
tree4ffeb1aec10226734b93960917476aef7020e25c /net-ftp/nvemftp
parentAdded another mirror for VMware Workstation 5.5.2, so it can be fetched prope... (diff)
downloadgentoo-2-fd2f063bfa7839697ea6ff89b80c426043227d97.tar.gz
gentoo-2-fd2f063bfa7839697ea6ff89b80c426043227d97.tar.bz2
gentoo-2-fd2f063bfa7839697ea6ff89b80c426043227d97.zip
Add patch to build with Qt 3.3.5, thanks to 'spiritus' in bug #155308.
(Portage version: 2.1.2_rc1-r7)
Diffstat (limited to 'net-ftp/nvemftp')
-rw-r--r--net-ftp/nvemftp/ChangeLog6
-rw-r--r--net-ftp/nvemftp/files/nvemftp-0.1.3+qt-3.3.5.patch22
-rw-r--r--net-ftp/nvemftp/nvemftp-0.1.3.ebuild4
3 files changed, 30 insertions, 2 deletions
diff --git a/net-ftp/nvemftp/ChangeLog b/net-ftp/nvemftp/ChangeLog
index 070ad0f5ee4b..c374769cdc4c 100644
--- a/net-ftp/nvemftp/ChangeLog
+++ b/net-ftp/nvemftp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/nvemftp
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/nvemftp/ChangeLog,v 1.7 2006/07/22 09:46:46 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/nvemftp/ChangeLog,v 1.8 2006/11/16 14:22:31 flameeyes Exp $
+
+ 16 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/nvemftp-0.1.3+qt-3.3.5.patch, nvemftp-0.1.3.ebuild:
+ Add patch to build with Qt 3.3.5, thanks to 'spiritus' in bug #155308.
22 Jul 2006; Simon Stelling <blubb@gentoo.org> nvemftp-0.1.3.ebuild:
marking -amd64 per bug 131750
diff --git a/net-ftp/nvemftp/files/nvemftp-0.1.3+qt-3.3.5.patch b/net-ftp/nvemftp/files/nvemftp-0.1.3+qt-3.3.5.patch
new file mode 100644
index 000000000000..ac6abb80d0d9
--- /dev/null
+++ b/net-ftp/nvemftp/files/nvemftp-0.1.3+qt-3.3.5.patch
@@ -0,0 +1,22 @@
+diff -ruB nvemftp-0.1.3.orig/plugins/nftp/nftpoptions.ui nvemftp-0.1.3/plugins/nftp/nftpoptions.ui
+--- nvemftp-0.1.3.orig/plugins/nftp/nftpoptions.ui 2006-11-16 04:33:33.000000000 +0500
++++ nvemftp-0.1.3/plugins/nftp/nftpoptions.ui 2006-11-16 04:35:14.000000000 +0500
+@@ -231,7 +231,4 @@
+ <function access="private" specifier="non virtual">init()</function>
+ </functions>
+ <layoutdefaults spacing="6" margin="11"/>
+-<includehints>
+- <includehint>nvemoptionswidget.h</includehint>
+-</includehints>
+ </UI>
+diff -ruB nvemftp-0.1.3.orig/src/nvemftpoptions.ui nvemftp-0.1.3/src/nvemftpoptions.ui
+--- nvemftp-0.1.3.orig/src/nvemftpoptions.ui 2006-11-16 04:33:33.000000000 +0500
++++ nvemftp-0.1.3/src/nvemftpoptions.ui 2006-11-16 04:35:02.000000000 +0500
+@@ -805,7 +805,4 @@
+ <function access="private" specifier="non virtual">init()</function>
+ </functions>
+ <layoutdefaults spacing="6" margin="11"/>
+-<includehints>
+- <includehint>nvemoptionswidget.h</includehint>
+-</includehints>
+ </UI>
diff --git a/net-ftp/nvemftp/nvemftp-0.1.3.ebuild b/net-ftp/nvemftp/nvemftp-0.1.3.ebuild
index 1f610913d148..925e9bba53df 100644
--- a/net-ftp/nvemftp/nvemftp-0.1.3.ebuild
+++ b/net-ftp/nvemftp/nvemftp-0.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/nvemftp/nvemftp-0.1.3.ebuild,v 1.6 2006/07/22 09:46:46 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/nvemftp/nvemftp-0.1.3.ebuild,v 1.7 2006/11/16 14:22:31 flameeyes Exp $
inherit kde
@@ -13,6 +13,8 @@ LICENSE="GPL-2"
KEYWORDS="-amd64 ~sparc ~x86"
IUSE=""
+PATCHES="${FILESDIR}/${P}+qt-3.3.5.patch"
+
need-qt 3
src_compile() {