summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-06-17 00:35:32 +0000
committerMichael Weber <xmw@gentoo.org>2011-06-17 00:35:32 +0000
commit883db4a8b4287b40d508d5e387a48b2f92cb83d3 (patch)
tree0a2290720580b747b6863574a1ed086a4e8b4f37 /net-ftp/oftpd/oftpd-0.3.7-r7.ebuild
parentStable for HPPA (bug #370997). (diff)
downloadgentoo-2-883db4a8b4287b40d508d5e387a48b2f92cb83d3.tar.gz
gentoo-2-883db4a8b4287b40d508d5e387a48b2f92cb83d3.tar.bz2
gentoo-2-883db4a8b4287b40d508d5e387a48b2f92cb83d3.zip
Revision bump, improvements in the conf.d file
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/oftpd/oftpd-0.3.7-r7.ebuild')
-rw-r--r--net-ftp/oftpd/oftpd-0.3.7-r7.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-ftp/oftpd/oftpd-0.3.7-r7.ebuild b/net-ftp/oftpd/oftpd-0.3.7-r7.ebuild
new file mode 100644
index 000000000000..3fa8c1661f32
--- /dev/null
+++ b/net-ftp/oftpd/oftpd-0.3.7-r7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/oftpd/oftpd-0.3.7-r7.ebuild,v 1.1 2011/06/17 00:35:32 xmw Exp $
+
+EAPI=2
+
+inherit autotools eutils
+
+DESCRIPTION="Secure, small, anonymous only ftpd"
+HOMEPAGE="http://www.time-travellers.org/oftpd"
+SRC_URI="http://www.time-travellers.org/oftpd/${P}.tar.gz
+ ftp://ftp.deepspace6.net/pub/ds6/sources/${PN}/${PN}-0.3.6-ipv6rel2.patch.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND="net-ftp/ftpbase"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ epatch "${FILESDIR}"/oftpd-0.3.7-ipv6rel2-0.3.6-to-0.3.7.patch
+
+ cd "${S}" || die
+ epatch "${WORKDIR}"/${PN}-0.3.6-ipv6rel2.patch
+
+ # Don't crash when using an unsupported address family, #159178.
+ # updated in bug #157005
+ epatch "${FILESDIR}"/${P}-family-1.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --bindir=/usr/sbin $(use_enable ipv6)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS FAQ NEWS README TODO || die
+ keepdir /home/ftp
+ newinitd "${FILESDIR}"/init.d.oftpd-r7 oftpd || die
+ newconfd "${FILESDIR}"/conf.d.oftpd-r7 oftpd || die
+}