summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2005-09-06 22:39:09 +0000
committerGustavo Felisberto <humpback@gentoo.org>2005-09-06 22:39:09 +0000
commitcb13bcaf95b531ff8b21b11aa8f3532d4aa601c9 (patch)
tree9a6d0d4a91e6bb37b674878d044ffb13417e9f3f /net-ftp/pureadmin/pureadmin-0.2.2.ebuild
parentMove patches to a patchset. Add fixes from Debian, support for lossless crop... (diff)
downloadgentoo-2-cb13bcaf95b531ff8b21b11aa8f3532d4aa601c9.tar.gz
gentoo-2-cb13bcaf95b531ff8b21b11aa8f3532d4aa601c9.tar.bz2
gentoo-2-cb13bcaf95b531ff8b21b11aa8f3532d4aa601c9.zip
bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-ftp/pureadmin/pureadmin-0.2.2.ebuild')
-rw-r--r--net-ftp/pureadmin/pureadmin-0.2.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-ftp/pureadmin/pureadmin-0.2.2.ebuild b/net-ftp/pureadmin/pureadmin-0.2.2.ebuild
new file mode 100644
index 000000000000..678f733cb8b3
--- /dev/null
+++ b/net-ftp/pureadmin/pureadmin-0.2.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.2.2.ebuild,v 1.1 2005/09/06 22:39:09 humpback Exp $
+
+inherit eutils
+IUSE="debug gnome doc"
+
+DESCRIPTION="PureAdmin is a GUI tool used to make the management of PureFTPd a little easier."
+HOMEPAGE="http://purify.sourceforge.net"
+SRC_URI="mirror://sourceforge/purify/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ~ppc"
+
+DEPEND="sys-libs/glibc
+ sys-libs/zlib
+ >=x11-libs/gtk+-2.0"
+
+src_compile() {
+ local myconf=""
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ # Move the docs to the correct location
+ if use doc; then
+ dodoc ${D}usr/share/doc/pureadmin/*.txt
+ rm -rf ${D}usr/share/doc/pureadmin
+ fi
+
+ make_desktop_entry pureadmin "Pure-ftp menu config" pureadmin
+}
+
+pkg_postinst() {
+ echo
+ ewarn "PureAdmin is at an alpha-stage right now and it may break"
+ ewarn "your configuration. DO NOT use it for safety critical system"
+ ewarn "or production use!"
+ echo
+ einfo "You need root-privileges to be able to use PureAdmin as for now."
+ einfo "This will probably change in the future."
+ echo
+}