summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-06-16 09:11:30 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-06-16 09:11:30 +0000
commit4ee044dea833cb804cf520456f61310d290c1e4d (patch)
treea66c8542e58da4f9d301bb151a439df661a1199d /net-ftp
parentVersion bump. (diff)
downloadgentoo-2-4ee044dea833cb804cf520456f61310d290c1e4d.tar.gz
gentoo-2-4ee044dea833cb804cf520456f61310d290c1e4d.tar.bz2
gentoo-2-4ee044dea833cb804cf520456f61310d290c1e4d.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/ChangeLog10
-rw-r--r--net-ftp/filezilla/filezilla-3.2.5.ebuild45
2 files changed, 54 insertions, 1 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
index 476ad03706a1..6f11550ca42e 100644
--- a/net-ftp/filezilla/ChangeLog
+++ b/net-ftp/filezilla/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-ftp/filezilla
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.43 2009/05/07 14:11:18 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.44 2009/06/16 09:11:30 voyageur Exp $
+
+*filezilla-3.2.5 (16 Jun 2009)
+
+ 16 Jun 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +filezilla-3.2.5.ebuild:
+ Version bump, adds remote file search, adds option to hide identical files
+ to directory comparison, remembers SSH keys for session duration if not
+ trusting permanently, and bugfixes (including gnutls pkg-config support)
*filezilla-3.2.4.1-r1 (07 May 2009)
diff --git a/net-ftp/filezilla/filezilla-3.2.5.ebuild b/net-ftp/filezilla/filezilla-3.2.5.ebuild
new file mode 100644
index 000000000000..79a3f914860e
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.2.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/filezilla-3.2.5.ebuild,v 1.1 2009/06/16 09:11:30 voyageur Exp $
+
+EAPI=2
+
+WX_GTK_VER="2.8"
+
+inherit eutils multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="dbus test"
+
+RDEPEND="net-dns/libidn
+ >=x11-libs/wxGTK-2.8.9
+ >=app-admin/eselect-wxwidgets-0.7-r1
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4
+ >=sys-devel/gettext-0.11
+ >=net-libs/gnutls-2.0.4
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_configure() {
+ econf $(use_with dbus) --disable-autoupdatecheck || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon src/interface/resources/48x48/${PN}.png || die "doicon failed"
+
+ dodoc AUTHORS ChangeLog NEWS
+}