summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-09-24 10:17:20 +0000
committerJeroen Roovers <jer@gentoo.org>2009-09-24 10:17:20 +0000
commit7c21d24933b178a6f0b20fe0f663163b6564b1d9 (patch)
tree30371275229919b41d5d5b3322e529747a13bc5b /net-ftp
parentStable on amd64 (bug #286137) (diff)
downloadgentoo-2-7c21d24933b178a6f0b20fe0f663163b6564b1d9.tar.gz
gentoo-2-7c21d24933b178a6f0b20fe0f663163b6564b1d9.tar.bz2
gentoo-2-7c21d24933b178a6f0b20fe0f663163b6564b1d9.zip
Version bump.
(Portage version: 2.2_rc41/cvs/Linux i686)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-4.0.2.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index c6752803d8c7..51aaaf6c6fd7 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.231 2009/09/23 18:36:50 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.232 2009/09/24 10:17:20 jer Exp $
+
+*lftp-4.0.2 (24 Sep 2009)
+
+ 24 Sep 2009; Jeroen Roovers <jer@gentoo.org> +lftp-4.0.2.ebuild:
+ Version bump.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> lftp-3.7.14.ebuild,
lftp-3.7.15-r1.ebuild:
diff --git a/net-ftp/lftp/lftp-4.0.2.ebuild b/net-ftp/lftp/lftp-4.0.2.ebuild
new file mode 100644
index 000000000000..05e81716c1d2
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.0.2.ebuild,v 1.1 2009/09/24 10:17:20 jer Exp $
+
+EAPI="2"
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ >=sys-libs/readline-5.1
+"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl
+ =sys-devel/libtool-2*
+"
+
+src_configure() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}