summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-13 20:39:01 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-13 20:39:01 +0000
commitf99eb0ea21837d5e26dc09240377279777a8c0b3 (patch)
treec944826fccc0ff288cc514be5f75628d6a9929da /net-im/ekg
parent- make lua partially cross compile aware. More work might be needed (diff)
downloadgentoo-2-f99eb0ea21837d5e26dc09240377279777a8c0b3.tar.gz
gentoo-2-f99eb0ea21837d5e26dc09240377279777a8c0b3.tar.bz2
gentoo-2-f99eb0ea21837d5e26dc09240377279777a8c0b3.zip
Version bump.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'net-im/ekg')
-rw-r--r--net-im/ekg/ChangeLog8
-rw-r--r--net-im/ekg/ekg-1.8_rc1.ebuild66
-rw-r--r--net-im/ekg/files/ekg-1.8_rc1-gtkutil-button-decl.patch9
3 files changed, 82 insertions, 1 deletions
diff --git a/net-im/ekg/ChangeLog b/net-im/ekg/ChangeLog
index 5e20d8a4a855..01a4d34db10d 100644
--- a/net-im/ekg/ChangeLog
+++ b/net-im/ekg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/ekg
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.40 2008/03/25 17:54:09 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.41 2008/09/13 20:39:00 spock Exp $
+
+*ekg-1.8_rc1 (13 Sep 2008)
+
+ 13 Sep 2008; Michał Januszewski <spock@gentoo.org>
+ +files/ekg-1.8_rc1-gtkutil-button-decl.patch, +ekg-1.8_rc1.ebuild:
+ Version bump.
25 Mar 2008; Santiago M. Mola <coldwind@gentoo.org>
-files/ekg-1.6-dragonfly.patch, -files/ekg-1.6_rc1-fpic.patch,
diff --git a/net-im/ekg/ekg-1.8_rc1.ebuild b/net-im/ekg/ekg-1.8_rc1.ebuild
new file mode 100644
index 000000000000..36f54d02c1f6
--- /dev/null
+++ b/net-im/ekg/ekg-1.8_rc1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.8_rc1.ebuild,v 1.1 2008/09/13 20:39:00 spock Exp $
+
+inherit eutils
+
+IUSE="gif gtk jpeg ncurses python readline spell ssl threads zlib"
+
+DESCRIPTION="EKG (Eksperymentalny Klient Gadu-Gadu) - a text client for Polish instant messaging system Gadu-Gadu"
+HOMEPAGE="http://ekg.chmurka.net/"
+SRC_URI="http://ekg.chmurka.net/${P/_/}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+
+S="${WORKDIR}/${P/_/}"
+
+RDEPEND="net-libs/libgadu
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ ncurses? ( sys-libs/ncurses )
+ readline? ( sys-libs/readline )
+ zlib? ( sys-libs/zlib )
+ python? ( dev-lang/python )
+ spell? ( >=app-text/aspell-0.50.3 )
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ gtk? ( >=x11-libs/gtk+-2.0 )"
+
+DEPEND=">=sys-devel/automake-1.7
+ >=sys-devel/autoconf-2.50
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gtkutil-button-decl.patch"
+}
+
+src_compile() {
+ local myconf="--enable-ioctld --disable-static --enable-dynamic"
+ if use ncurses; then
+ myconf="$myconf --enable-force-ncurses"
+ else
+ myconf="$myconf --disable-ui-ncurses"
+ fi
+ use readline && myconf="$myconf --enable-ui-readline"
+
+ econf ${myconf} \
+ `use_with python` \
+ `use_with threads pthread` \
+ `use_with jpeg libjpeg` \
+ `use_with gif libgif` \
+ `use_with zlib` \
+ `use_enable spell aspell` \
+ `use_with ssl openssl` \
+ `use_enable ssl openssl` \
+ `use_enable gtk ui-gtk` \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc docs/{*.txt,ULOTKA,TODO,README,FAQ}
+}
diff --git a/net-im/ekg/files/ekg-1.8_rc1-gtkutil-button-decl.patch b/net-im/ekg/files/ekg-1.8_rc1-gtkutil-button-decl.patch
new file mode 100644
index 000000000000..b3bac90416b3
--- /dev/null
+++ b/net-im/ekg/files/ekg-1.8_rc1-gtkutil-button-decl.patch
@@ -0,0 +1,9 @@
+diff -Naurp ekg-1.8rc1-orig/src/ui-gtk-chanview-tabs.c ekg-1.8rc1/src/ui-gtk-chanview-tabs.c
+--- ekg-1.8rc1-orig/src/ui-gtk-chanview-tabs.c 2008-09-13 22:33:25.000000000 +0200
++++ ekg-1.8rc1/src/ui-gtk-chanview-tabs.c 2008-09-13 22:33:48.000000000 +0200
+@@ -1,4 +1,5 @@
+ /* file included in chanview.c */
++GtkWidget *gtkutil_button(GtkWidget *box, char *stock, char *tip, void *callback, void *userdata, char *labeltext);
+
+ typedef struct {
+ GtkWidget *outer; /* outer box */