summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-05-29 12:06:54 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-05-29 12:06:54 +0000
commitb56cc3c2453886f43be14f834630b0b2fc871b33 (patch)
tree58aff4be7c98c9a5e300ffb6a97a1f507510694b /net-im/emesene/emesene-1.6.3.ebuild
parentMasking emesene:2 (diff)
downloadgentoo-2-b56cc3c2453886f43be14f834630b0b2fc871b33.tar.gz
gentoo-2-b56cc3c2453886f43be14f834630b0b2fc871b33.tar.bz2
gentoo-2-b56cc3c2453886f43be14f834630b0b2fc871b33.zip
Initial commit. Bug #211174 and Bug #256747
(Portage version: 2.2.0_alpha36/cvs/Linux x86_64)
Diffstat (limited to 'net-im/emesene/emesene-1.6.3.ebuild')
-rw-r--r--net-im/emesene/emesene-1.6.3.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-im/emesene/emesene-1.6.3.ebuild b/net-im/emesene/emesene-1.6.3.ebuild
new file mode 100644
index 000000000000..fbbb5e8f3251
--- /dev/null
+++ b/net-im/emesene/emesene-1.6.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/emesene/emesene-1.6.3.ebuild,v 1.1 2011/05/29 12:06:54 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python eutils
+
+DESCRIPTION="Platform independent MSN Messenger client written in Python+GTK"
+HOMEPAGE="http://www.emesene.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="webcam"
+
+RDEPEND="dev-python/pygtk:2
+ dev-python/gst-python
+ webcam? ( media-plugins/gst-plugins-meta[v4l2] )"
+
+src_prepare() {
+ rm GPL PSF LGPL || die "rm license files failed"
+
+ if ! use webcam; then
+ rm -r libmimic || die "rm libmimic dir failed"
+ fi
+}
+
+src_compile() {
+ if use webcam ; then
+ $(PYTHON) ./setup.py build_ext -i || die "libmimic compile failed"
+ fi
+}
+
+src_install() {
+ if use webcam; then
+ rm -r build || die "rm build failed"
+ fi
+
+ insinto /usr/share/${PN}
+ doins -r * || die "doins failed"
+
+ fperms a+x /usr/share/${PN}/${PN} || die "fperms failed"
+ dosym /usr/share/${PN}/${PN} /usr/bin/${PN} || die "dosym failed"
+
+ doman misc/${PN}.1 || die "doman failed"
+
+ doicon misc/*.{svg,png} || die "doicon failed"
+
+ # install the desktop entry
+ domenu misc/${PN}.desktop || die "domenu failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+
+ elog "If you want to use the spell-checking feature, you should emerge"
+ elog "dev-python/gtkspell-python"
+ elog
+ elog "If you want to use EncryptMessage plugin, you should emerge"
+ elog "dev-python/pexpect"
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}