summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-23 19:50:08 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-23 19:50:08 +0000
commit93d2fcaa67aceeb6b754348da12eae03c4f76ac4 (patch)
treee8973d76208a6fde5383b2c24e2e39abf0f469f9 /net-im/gajim
parentAdded a patch which makes sure cblas stock libraries are used instead of bund... (diff)
downloadgentoo-2-93d2fcaa67aceeb6b754348da12eae03c4f76ac4.tar.gz
gentoo-2-93d2fcaa67aceeb6b754348da12eae03c4f76ac4.tar.bz2
gentoo-2-93d2fcaa67aceeb6b754348da12eae03c4f76ac4.zip
net-im/gajim: Backport upstream commit 13748 to fix plugin dir location, #411253
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/ChangeLog8
-rw-r--r--net-im/gajim/files/gajim-0.15-plugin.patch15
-rw-r--r--net-im/gajim/gajim-0.15-r1.ebuild102
3 files changed, 124 insertions, 1 deletions
diff --git a/net-im/gajim/ChangeLog b/net-im/gajim/ChangeLog
index d4f6eaa2a86d..84e0ee1f8ccf 100644
--- a/net-im/gajim/ChangeLog
+++ b/net-im/gajim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gajim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.134 2012/03/26 23:13:11 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.135 2012/04/23 19:50:08 jlec Exp $
+
+*gajim-0.15-r1 (23 Apr 2012)
+
+ 23 Apr 2012; Justin Lecher <jlec@gentoo.org> +gajim-0.15-r1.ebuild,
+ +files/gajim-0.15-plugin.patch:
+ Backport upstream commit 13748 to fix plugin dir location, #411253
26 Mar 2012; Naohiro Aota <naota@gentoo.org> gajim-0.15.ebuild:
Add ~x86-fbsd. #408687
diff --git a/net-im/gajim/files/gajim-0.15-plugin.patch b/net-im/gajim/files/gajim-0.15-plugin.patch
new file mode 100644
index 000000000000..fa52ddac24c5
--- /dev/null
+++ b/net-im/gajim/files/gajim-0.15-plugin.patch
@@ -0,0 +1,15 @@
+--- configure.ac (revision 13405)
++++ configure.ac (revision 13748)
+@@ -48,9 +48,9 @@
+ ,
+ AC_SUBST([gajim_srcdir], [\${pkgpythondir}])
+-AC_SUBST([gajim_pluginsdir], [\${pkgpythondir}])
+ ,
+ AC_SUBST([gajim_srcdir], [\${datadir}/\${PACKAGE}/src])
++)
++
+ AC_SUBST([gajim_pluginsdir], [\${datadir}/\${PACKAGE}/plugins])
+-)
+
+ AS_AC_EXPAND(GAJIM_SRCDIR, "${gajim_srcdir}")
+
diff --git a/net-im/gajim/gajim-0.15-r1.ebuild b/net-im/gajim/gajim-0.15-r1.ebuild
new file mode 100644
index 000000000000..a79bf354824a
--- /dev/null
+++ b/net-im/gajim/gajim-0.15-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.15-r1.ebuild,v 1.1 2012/04/23 19:50:08 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite xml"
+
+inherit autotools eutils python versionator
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="http://www.gajim.org/"
+SRC_URI="http://www.gajim.org/downloads/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi crypt dbus gmail gnome kde idle jingle libnotify networkmanager nls spell srv X xhtml"
+
+REQUIRED_USE="
+ libnotify? ( dbus )
+ avahi? ( dbus )"
+
+COMMON_DEPEND="
+ dev-python/pygtk:2
+ x11-libs/gtk+:2"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.1
+ dev-util/pkgconfig
+ >=sys-devel/gettext-0.17-r1"
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyasn1
+ dev-python/pyopenssl
+ crypt? (
+ app-crypt/gnupg
+ dev-python/pycrypto
+ )
+ dbus? (
+ dev-python/dbus-python
+ dev-libs/dbus-glib
+ libnotify? ( dev-python/notify-python )
+ avahi? ( net-dns/avahi[dbus,gtk,python] )
+ )
+ gmail? ( net-dns/bind-tools )
+ gnome? (
+ dev-python/libgnome-python
+ dev-python/gnome-keyring-python
+ dev-python/egg-python
+ )
+ idle? ( x11-libs/libXScrnSaver )
+ jingle? ( net-libs/farsight2[python] )
+ kde? ( kde-base/kwallet )
+ networkmanager? (
+ dev-python/dbus-python
+ net-misc/networkmanager
+ )
+ srv? (
+ || (
+ dev-python/libasyncns-python
+ net-dns/bind-tools )
+ )
+ spell? ( app-text/gtkspell:2 )
+ xhtml? ( dev-python/docutils )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-plugin.patch \
+ "${FILESDIR}"/0.14-python-version.patch \
+ "${FILESDIR}"/0.14.1-testing.patch
+ echo '#!/bin/sh' > config/py-compile
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with X x) \
+ --docdir="/usr/share/doc/${PF}" \
+ --libdir="$(python_get_sitedir)" \
+ --enable-site-packages
+}
+
+src_install() {
+ default
+
+ rm "${D}/usr/share/doc/${PF}/README.html" || die
+ dohtml README.html
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}