summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-11-02 20:59:04 +0000
committerNick Hadaway <raker@gentoo.org>2002-11-02 20:59:04 +0000
commite6fbf0182623dbe56fd10705604a549cd3f12d5c (patch)
treec44d959c4bb3ec1da49c2755fafb15ae5b4af73d /net-im/gnophone
parentInitial ebuild added to portage. See bug #7724 (diff)
downloadgentoo-2-e6fbf0182623dbe56fd10705604a549cd3f12d5c.tar.gz
gentoo-2-e6fbf0182623dbe56fd10705604a549cd3f12d5c.tar.bz2
gentoo-2-e6fbf0182623dbe56fd10705604a549cd3f12d5c.zip
Initial ebuild added to portage. See bug #7723
Diffstat (limited to 'net-im/gnophone')
-rw-r--r--net-im/gnophone/ChangeLog12
-rw-r--r--net-im/gnophone/files/digest-gnophone-0.2.41
-rw-r--r--net-im/gnophone/gnophone-0.2.4.ebuild67
3 files changed, 80 insertions, 0 deletions
diff --git a/net-im/gnophone/ChangeLog b/net-im/gnophone/ChangeLog
new file mode 100644
index 000000000000..7ead3a5a1002
--- /dev/null
+++ b/net-im/gnophone/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-im/gnophone
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnophone/ChangeLog,v 1.1 2002/11/02 20:59:04 raker Exp $
+
+*gnophone-0.2.4 (27 Jul 2002)
+
+ 02 Nov 2002; Nick Hadaway <raker@gentoo.org> gnophone-0.2.4.ebuild :
+ Added IUSE and KEYWORDS.
+
+ 27 Jul 2002; Sean Summers <ebuild@generalprotectionfault.com> gnophone-0.2.4.ebuild :
+ Initial package
+
diff --git a/net-im/gnophone/files/digest-gnophone-0.2.4 b/net-im/gnophone/files/digest-gnophone-0.2.4
new file mode 100644
index 000000000000..d9f49af9de92
--- /dev/null
+++ b/net-im/gnophone/files/digest-gnophone-0.2.4
@@ -0,0 +1 @@
+MD5 75cee76acbd930ccdf473352b1beab30 gnophone-0.2.4.tar.gz 467136
diff --git a/net-im/gnophone/gnophone-0.2.4.ebuild b/net-im/gnophone/gnophone-0.2.4.ebuild
new file mode 100644
index 000000000000..3411524ee3fd
--- /dev/null
+++ b/net-im/gnophone/gnophone-0.2.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnophone/gnophone-0.2.4.ebuild,v 1.1 2002/11/02 20:59:04 raker Exp $
+
+IUSE=""
+
+DESCRIPTION="internet telephone"
+HOMEPAGE="http://www.gnophone.com/"
+LICENSE="GPL-2"
+DEPEND="media-sound/gsm
+ net-libs/iax
+ media-sound/sox
+ mozilla? ( net-www/mozilla )
+ esd? ( media-sound/esound )
+ x11-libs/gtk+
+ media-libs/gdk-pixbuf
+ dev-libs/glib
+ sys-devel/ld.so
+ x11-base/xfree
+ media-libs/imlib
+ virtual/glibc"
+RDEPEND="media-sound/gsm
+ net-libs/iax
+ media-sound/sox
+ mozilla? ( net-www/mozilla )
+ esd? ( media-sound/esound )
+ x11-libs/gtk+
+ media-libs/gdk-pixbuf
+ dev-libs/glib
+ sys-devel/ld.so
+ x11-base/xfree
+ media-libs/imlib
+ virtual/glibc"
+SLOT="0"
+SRC_URI="ftp://ftp.gnophone.com/pub/gnophone/${P}.tar.gz"
+
+S=${WORKDIR}/${P}
+
+D_PREFIX=/usr
+
+KEYWORDS="x86"
+
+src_compile() {
+ local myconf
+
+ use mozilla \
+ && myconf="${myconf}
+ --with-mozilla-home=/usr/lib/mozilla
+ --with-mozilla-lib=/usr/lib/mozilla
+ --with-mozilla-include=/usr/lib/mozilla/include" \
+ || myconf="${myconf} --disable-mozilla"
+ use esd \
+ || myconf="${myconf} --disable-esd"
+
+ ./configure ${myconf} \
+ --prefix=${D_PREFIX} --enable-upgrade --disable-zaptel \
+ || die "./configure failed"
+
+ pushd ${S}/sounds && make && popd # -j2 breaks the sound build
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/${D_PREFIX} install
+ dodoc NEWS COPYING AUTHORS README
+}