summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-07-02 00:56:59 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-07-02 00:56:59 +0000
commit03a791c69590a118b78f000b80d78926502d3197 (patch)
tree7dabcb1539ec7fc323e5e50457f3fc54e56ac213 /net-im/gyach/gyach-0.9.7-r1.ebuild
parentSecurity updates; Fixes for sparse/e1000 bugs for 2.4 and the packet of death... (diff)
downloadgentoo-2-03a791c69590a118b78f000b80d78926502d3197.tar.gz
gentoo-2-03a791c69590a118b78f000b80d78926502d3197.tar.bz2
gentoo-2-03a791c69590a118b78f000b80d78926502d3197.zip
*** empty log message ***
Diffstat (limited to 'net-im/gyach/gyach-0.9.7-r1.ebuild')
-rw-r--r--net-im/gyach/gyach-0.9.7-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-im/gyach/gyach-0.9.7-r1.ebuild b/net-im/gyach/gyach-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..c77ea045d118
--- /dev/null
+++ b/net-im/gyach/gyach-0.9.7-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gyach/gyach-0.9.7-r1.ebuild,v 1.1 2004/07/02 00:56:59 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+-based Yahoo! chat client"
+SRC_URI="http://www4.infi.net/~cpinkham/gyach/code/${P}.tar.gz"
+HOMEPAGE="http://www4.infi.net/~cpinkham/gyach/"
+KEYWORDS="x86 sparc "
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ =x11-libs/gtk+-2*"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/gyach-${PV}-yahoo-auth-2004-06-24.diff
+}
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL README* TODO
+ dodoc sample.*
+
+ # install icon and desktop entry for gnome
+ if use gnome ; then
+ insinto /usr/share/pixmaps
+ doins ${D}/usr/share/gyach/pixmaps/gyach-icon.xpm
+ insinto /usr/share/gnome/apps/Internet
+ doins ${FILESDIR}/gyach.desktop
+ fi
+}