summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-06 17:25:33 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-06 17:25:33 +0000
commit259520b563aa04106f09070957de0f90792ccfba (patch)
tree0353403903cda23e24615f4393618882c27d961c /net-im/ohphone
parentInitial import (diff)
downloadgentoo-2-259520b563aa04106f09070957de0f90792ccfba.tar.gz
gentoo-2-259520b563aa04106f09070957de0f90792ccfba.tar.bz2
gentoo-2-259520b563aa04106f09070957de0f90792ccfba.zip
updated ohphone to make svga and X optional
Diffstat (limited to 'net-im/ohphone')
-rw-r--r--net-im/ohphone/ChangeLog9
-rw-r--r--net-im/ohphone/Manifest4
-rw-r--r--net-im/ohphone/files/digest-ohphone-1.4.1-r11
-rw-r--r--net-im/ohphone/ohphone-1.4.1-r1.ebuild54
4 files changed, 66 insertions, 2 deletions
diff --git a/net-im/ohphone/ChangeLog b/net-im/ohphone/ChangeLog
index 0c2995627bcb..1fb80a00b831 100644
--- a/net-im/ohphone/ChangeLog
+++ b/net-im/ohphone/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/ohphone
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ohphone/ChangeLog,v 1.1 2003/09/03 10:35:59 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ohphone/ChangeLog,v 1.2 2003/09/06 17:25:24 liquidx Exp $
+
+*ohphone-1.4.1-r1 (06 Sep 2003)
+
+ 06 Sep 2003; Alastair Tse <liquidx@gentoo.org> ohphone-1.4.1-r1.ebuild:
+ added optional X and svgalib support, although in essense, if SDL support was
+ enabled with pwlib, it'll still be compiled in. also updated the deps to
+ newest openh323 and pwlib
*ohphone-1.4.1 (03 Sep 2003)
diff --git a/net-im/ohphone/Manifest b/net-im/ohphone/Manifest
index d6f5dcd65211..8a83a78cf421 100644
--- a/net-im/ohphone/Manifest
+++ b/net-im/ohphone/Manifest
@@ -1,4 +1,6 @@
-MD5 7ac6272351608f61ad615ed889b4a2ad ChangeLog 377
+MD5 3647db9025bdbe773cd22382621fc772 ChangeLog 668
MD5 8f906ffe0aa837e5e26fe03af3043461 metadata.xml 219
+MD5 776c765cddfe7a706b35fe81d832ca0f ohphone-1.4.1-r1.ebuild 1205
MD5 8b50877e6e0496c9635e449b3cbc5ee6 ohphone-1.4.1.ebuild 821
MD5 eb00a184805b4c495b46976ce6ccfbbf files/digest-ohphone-1.4.1 64
+MD5 eb00a184805b4c495b46976ce6ccfbbf files/digest-ohphone-1.4.1-r1 64
diff --git a/net-im/ohphone/files/digest-ohphone-1.4.1-r1 b/net-im/ohphone/files/digest-ohphone-1.4.1-r1
new file mode 100644
index 000000000000..e5214e0aca56
--- /dev/null
+++ b/net-im/ohphone/files/digest-ohphone-1.4.1-r1
@@ -0,0 +1 @@
+MD5 f5b975db51589e2ed741367e20f75ed0 ohphone_1.4.1.tar.gz 77085
diff --git a/net-im/ohphone/ohphone-1.4.1-r1.ebuild b/net-im/ohphone/ohphone-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..e9334aa4b70a
--- /dev/null
+++ b/net-im/ohphone/ohphone-1.4.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ohphone/ohphone-1.4.1-r1.ebuild,v 1.1 2003/09/06 17:25:24 liquidx Exp $
+
+DESCRIPTION="Command line H.323 client"
+HOMEPAGE="http://www.openh323.org/"
+SRC_URI="http://www.openh323.org/bin/${PN}_${PV}.tar.gz"
+
+LICENSE="MPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X"
+
+DEPEND=">=net-libs/openh323-1.12.2
+ >=dev-libs/pwlib-1.5.2
+ X? ( virtual/x11 )
+ svga? ( media-libs/svga )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+
+ use svga \
+ || sed -e "s:-lvga::" -e "s:-DHAS_VGALIB::" -i ${S}/Makefile \
+ || die "failed to turn off SVGAlib support"
+}
+
+src_compile() {
+ local myopts
+
+ use X \
+ && myopts="${myopts} XINCDIR=/usr/X11R6/include XLIBDIR=/usr/X11R6/lib" \
+ || myopts="${myopts} XINCDIR=/dev/null XLIBDIR=/dev/null"
+
+ emake \
+ OPENH323DIR=/usr/share/openh323 \
+ PREFIX=/usr \
+ PWLIBDIR=/usr/share/pwlib \
+ PW_LIBDIR=/usr/lib \
+ OH323_LIBDIR=/usr/lib \
+ ${myopts} \
+ opt man || die
+}
+
+src_install() {
+ cd ${WORKDIR}/${PN}
+ doman ohphone.1
+
+ # fill in for other archs
+ if [ ${ARCH} = "x86" ]; then
+ dobin obj_linux_x86_r/ohphone
+ fi
+}